projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5055755
)
set LINUX_KARCH in target/linux/rules.mk
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 11 Jan 2006 20:25:55 +0000
(20:25 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 11 Jan 2006 20:25:55 +0000
(20:25 +0000)
SVN-Revision: 2922
openwrt/target/linux/rules.mk
patch
|
blob
|
history
diff --git
a/openwrt/target/linux/rules.mk
b/openwrt/target/linux/rules.mk
index ec906fe1867647c2e60f8ab2989deccbc2e0c170..5ba43deea0efc703e93da12d3d5441970b50562a 100644
(file)
--- a/
openwrt/target/linux/rules.mk
+++ b/
openwrt/target/linux/rules.mk
@@
-1,3
+1,10
@@
+LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+ -e 's/mipsel/mips/' \
+ -e 's/mipseb/mips/' \
+ -e 's/powerpc/ppc/' \
+ -e 's/sh[234]/sh/' \
+)
+
define KMOD_template
ifeq ($$(strip $(4)),)
KDEPEND_$(1):=m