projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b7c1f24
)
cmake.mk: add support for overriding the source dir, and define the cmake prefix...
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 29 Dec 2012 11:12:31 +0000
(11:12 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 29 Dec 2012 11:12:31 +0000
(11:12 +0000)
SVN-Revision: 34914
include/cmake.mk
patch
|
blob
|
history
diff --git
a/include/cmake.mk
b/include/cmake.mk
index 4c4af502cc3889955c5ad69aef78f8f97cf54bb1..64a0654f9685004de625b22279ac58596105cc1b 100644
(file)
--- a/
include/cmake.mk
+++ b/
include/cmake.mk
@@
-4,6
+4,8
@@
ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
MAKE_FLAGS+=VERBOSE=1
endif
+CMAKE_SOURCE_DIR:=.
+
ifeq ($(CONFIG_CCACHE),)
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
CMAKE_C_COMPILER:=$(TOOLCHAIN_DIR)/bin/$(TARGET_CC)
@@
-53,8
+55,9
@@
define Build/Configure/Default
-DCMAKE_STRIP=: \
-DCMAKE_INSTALL_PREFIX=/usr \
-DDL_LIBRARY=$(STAGING_DIR) \
+ -DCMAKE_PREFIX_PATH=$(STAGING_DIR) \
$(CMAKE_OPTIONS) \
-
.
\
+
$(CMAKE_SOURCE_DIR)
\
)
endef