imagebuilder: fix copying of missing kernel/libc
authorPaul Spooren <mail@aparcar.org>
Wed, 30 Oct 2024 12:41:23 +0000 (13:41 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 30 Oct 2024 13:17:34 +0000 (14:17 +0100)
Those packages were not copied due to OPKG using an underscore while APK
uses dashes. Remove that char to copy kernel/libc for either APK/OPKG.

Signed-off-by: Paul Spooren <mail@aparcar.org>
target/imagebuilder/Makefile
target/imagebuilder/files/Makefile

index 1e58fad8e9adbb044d0c14bd7fa5267d7413f0bc..bdbbb45cb1f7e3b52e6da804448f7290837a6b18 100644 (file)
@@ -71,7 +71,7 @@ endif
 ifeq ($(CONFIG_BUILDBOT),)
   ifeq ($(CONFIG_IB_STANDALONE),)
        $(FIND) $(call FeedPackageDir,libc) -type f \
-               \( -name 'libc_*.$(PACKAGE_SUFFIX)' -or -name 'kernel_*.$(PACKAGE_SUFFIX)' -or -name 'kmod-*.$(PACKAGE_SUFFIX)' \) \
+               \( -name 'libc*.$(PACKAGE_SUFFIX)' -or -name 'kernel*.$(PACKAGE_SUFFIX)' -or -name 'kmod-*.$(PACKAGE_SUFFIX)' \) \
                -exec $(CP) -t $(PKG_BUILD_DIR)/packages {} +
   else
        $(FIND) $(wildcard $(PACKAGE_SUBDIRS)) -type f -name '*.$(PACKAGE_SUFFIX)' \
@@ -79,7 +79,7 @@ ifeq ($(CONFIG_BUILDBOT),)
   endif
 else
        $(FIND) $(call FeedPackageDir,libc) -type f \
-               \( -name 'libc_*.$(PACKAGE_SUFFIX)' -or -name 'kernel_*.$(PACKAGE_SUFFIX)' \) \
+               \( -name 'libc*.$(PACKAGE_SUFFIX)' -or -name 'kernel*.$(PACKAGE_SUFFIX)' \) \
                -exec $(CP) -t $(IB_LDIR)/ {} +
 endif
 
index 24de26c7712786af6234efaec5ecdb6c13a040de..f46b61b7870670692176f0dc9f1b343d29a3a88e 100644 (file)
@@ -228,8 +228,8 @@ ifeq ($(CONFIG_USE_APK),)
        $(OPKG) install $(firstword $(wildcard $(LINUX_DIR)/kernel_*.ipk $(PACKAGE_DIR)/kernel_*.ipk))
        $(OPKG) install $(BUILD_PACKAGES)
 else
-       $(APK) add --no-scripts $(firstword $(wildcard $(LINUX_DIR)/libc-*.apk $(PACKAGE_DIR)/libc_*.apk))
-       $(APK) add --no-scripts $(firstword $(wildcard $(LINUX_DIR)/kernel-*.apk $(PACKAGE_DIR)/kernel_*.apk))
+       $(APK) add --no-scripts $(firstword $(wildcard $(LINUX_DIR)/libc-*.apk $(PACKAGE_DIR)/libc-*.apk))
+       $(APK) add --no-scripts $(firstword $(wildcard $(LINUX_DIR)/kernel-*.apk $(PACKAGE_DIR)/kernel-*.apk))
        $(APK) add --no-scripts $(BUILD_PACKAGES)
 endif