ignore empty passwords in busybox httpd
authorFelix Fietkau <nbd@openwrt.org>
Mon, 2 Oct 2006 17:38:17 +0000 (17:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 2 Oct 2006 17:38:17 +0000 (17:38 +0000)
SVN-Revision: 4885

openwrt/package/busybox/Makefile
openwrt/package/busybox/patches/310-passwd_access.patch

index de56dcc84da0beeca905ae8dd5fb567aa3fb7df7..fbddbf0debc0665a15e36f8e0ea44f0060d77417 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 ifeq ($(strip $(BR2_PACKAGE_BUSYBOX_SNAPSHOT)),y)
 # Be aware that this changes daily....
index 03cfe8b8507f10bb618470b963322ee74442b43f..4ecb0d61d4d1147eb42eb9813e893981954decc4 100644 (file)
@@ -1,7 +1,7 @@
 diff -urN busybox.old/networking/httpd.c busybox.dev/networking/httpd.c
 --- busybox.old/networking/httpd.c     2004-10-08 10:03:29.000000000 +0200
 +++ busybox.dev/networking/httpd.c     2006-02-04 01:54:19.688016250 +0100
-@@ -1467,12 +1467,22 @@
+@@ -1467,12 +1467,24 @@
                {
                        char *cipher;
                        char *pp;
@@ -13,6 +13,8 @@ diff -urN busybox.old/networking/httpd.c busybox.dev/networking/httpd.c
                                continue;
                        }
                        pp = strchr(p, ':');
++                      if(pp && pp[1] == '!' && pp[2] == ':')
++                              continue;
 +                      if(pp && pp[1] == '$' && pp[2] == 'p' &&
 +                                               pp[3] == '$' && pp[4] &&
 +                                               (pwd = getpwnam(&pp[4])) != NULL) {