projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
01f0c2b
)
python-sip: Check for python-dev prereq
author
Michael Büsch
<mb@bu3sch.de>
Sat, 23 Oct 2010 20:16:12 +0000
(20:16 +0000)
committer
Michael Büsch
<mb@bu3sch.de>
Sat, 23 Oct 2010 20:16:12 +0000
(20:16 +0000)
SVN-Revision: 23597
lang/python-sip/Makefile
patch
|
blob
|
history
diff --git
a/lang/python-sip/Makefile
b/lang/python-sip/Makefile
index 6f50adfa02fd845bba9aaca809bc9b7e27e2afab..3b9368e7e9b92df77daa7f10efeeb2b0c0d86421 100644
(file)
--- a/
lang/python-sip/Makefile
+++ b/
lang/python-sip/Makefile
@@
-127,7
+127,16
@@
define Host/Install
install
endef
-#TODO check for host python-dev headers.
+define Require/python2-dev
+ [ -e /usr/include/Python.h ] || \
+ [ -e /usr/include/python/Python.h ] || \
+ [ -e /usr/include/python2.5/Python.h ] || \
+ [ -e /usr/include/python2.6/Python.h ]
+endef
+
+$(eval $(call Require,python2-dev, \
+ Please install Python 2.x headers (python-dev) \
+))
$(eval $(call RequireCommand,python, \
Please install Python 2.x \