build: prereq detect Python 3.10 for `python3` binary
authorPaul Spooren <mail@aparcar.org>
Sun, 10 Oct 2021 09:09:46 +0000 (23:09 -1000)
committerPaul Spooren <mail@aparcar.org>
Wed, 13 Oct 2021 05:19:30 +0000 (19:19 -1000)
While the binary `python3.10` is correctly detected by the build system
the default `python3` binary is currently not detected if pointing to a
Python 3.10 installation.

Fix this by extending the grep regex.

Signed-off-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit 56ea2bf2eec431ccd3c566190a444ad63db39b65)

include/prereq-build.mk

index 8b6413564db482bc8833288c28c6839b188051f9..d28432f726acbfd9b11d5d630408f6cc16850554 100644 (file)
@@ -159,7 +159,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
        python3.5 -V 2>&1 | grep 'Python 3', \
-       python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+       python3 -V 2>&1 | grep -E 'Python 3\.([5-9]|10)\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
        python3.10 -V 2>&1 | grep 'Python 3', \
@@ -168,7 +168,7 @@ $(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
        python3.5 -V 2>&1 | grep 'Python 3', \
-       python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+       python3 -V 2>&1 | grep -E 'Python 3\.([5-9]|10)\.?'))
 
 $(eval $(call TestHostCommand,python3-distutils, \
        Please install the Python3 distutils module, \