projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
38f7145
)
generate an uImage binary for now
author
Imre Kaloz
<kaloz@openwrt.org>
Tue, 23 Jun 2009 21:06:05 +0000
(21:06 +0000)
committer
Imre Kaloz
<kaloz@openwrt.org>
Tue, 23 Jun 2009 21:06:05 +0000
(21:06 +0000)
SVN-Revision: 16549
target/linux/coldfire/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/coldfire/image/Makefile
b/target/linux/coldfire/image/Makefile
index 5eb5c2f2f132e599a5873983590f710c0eb3269e..0228a8dcf65f7c06667f676710b4d31527194fb4 100644
(file)
--- a/
target/linux/coldfire/image/Makefile
+++ b/
target/linux/coldfire/image/Makefile
@@
-13,6
+13,11
@@
define Image/Prepare
endef
define Image/BuildKernel
+ $(TARGET_CROSS)objcopy -O binary -R .bss -R .note -R .comment \
+ -R .note.gnu.build-id -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.bin
+ mkimage -A m68k -O linux -T kernel -a 0x00020000 -e 0x00020000 \
+ -C none -n 'M68K OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.bin $(BIN_DIR)/openwrt-$(BOARD)-uImage
endef
define Image/Build