projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
4664a13
)
fix module autoload option
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 17 Oct 2006 21:43:41 +0000
(21:43 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 17 Oct 2006 21:43:41 +0000
(21:43 +0000)
SVN-Revision: 5201
include/kernel.mk
patch
|
blob
|
history
diff --git
a/include/kernel.mk
b/include/kernel.mk
index 92738172506d841a3332315194aef3fc51c3e0fc..7c0ba6d7dd7e92afd797c57e80e9f17ca2646096 100644
(file)
--- a/
include/kernel.mk
+++ b/
include/kernel.mk
@@
-70,7
+70,11
@@
define ModuleAutoLoad
export modules=; \
add_module() { \
mkdir -p $(2)/etc/modules.d; \
- echo "$$$$$$$$2" > $(2)/etc/modules.d/$$$$$$$$1-$(1); \
+ ( \
+ for mod in $$$$$$$$2; do \
+ getvar mod; \
+ done \
+ ) > $(2)/etc/modules.d/$$$$$$$$1-$(1); \
modules="$$$$$$$${modules:+$$$$$$$$modules }$$$$$$$$1-$(1)"; \
}; \
$(3) \