ar71xx: Add usb drivers in Archer C7 v4/v5 images
authorDaniel Halmschlager <dh@dev.halms.at>
Tue, 4 Dec 2018 19:40:10 +0000 (20:40 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:48:22 +0000 (17:48 +0100)
This commit adds the default usb packages
- kmod-usb-core
- kmod-usb2
- kmod-usb-ledtrig-usbport
for Archer C7 v4 and v5.
(The C7 v5 configuration is based on the v4, therefore the change for v4
also applies for v5.)

Signed-off-by: Daniel Halmschlager <dh@dev.halms.at>
(backported from 99e212171abf44d6e0f7e7ba50a229ad7b3f3a34)

target/linux/ar71xx/image/generic-tp-link.mk

index 812cb8d49a6d4df8b7dc06727611cddf7edd715d..ffc56a55d55945b6bba1225e898004de59807bac 100644 (file)
@@ -142,7 +142,7 @@ TARGET_DEVICES += tl-wdr7500-v3
 define Device/archer-c7-v4
   $(Device/archer-cxx)
   DEVICE_TITLE := TP-LINK Archer C7 v4
-  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca988x-ct
   BOARDNAME := ARCHER-C7-V4
   TPLINK_BOARD_ID := ARCHER-C7-V4
   IMAGE_SIZE := 15104k