adjust Makefile to not workaround weird libtool issues anymore
authorMirko Vogt <mirko@openwrt.org>
Sat, 4 Dec 2010 22:04:34 +0000 (22:04 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 4 Dec 2010 22:04:34 +0000 (22:04 +0000)
SVN-Revision: 24256

libs/jpeg/Makefile

index a1522c0032fc89be44c84517452a8be4d6af65fa..ab940ca612128219e4c3c04a4e5695911489e6fb 100644 (file)
@@ -52,20 +52,9 @@ HOST_CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
-define Build/Prepare
-       $(call Build/Prepare/Default)
-       # replace the old upstream libtool stuff with our own
-       ln -sf $(STAGING_DIR)/host/bin/libtool $(PKG_BUILD_DIR)/
-       ln -sf $(STAGING_DIR)/host/share/libtool/config.sub $(PKG_BUILD_DIR)/
-       ln -sf $(STAGING_DIR)/host/share/libtool/config.guess $(PKG_BUILD_DIR)/
-       ln -sf $(STAGING_DIR)/host/share/libtool/ltmain.sh $(PKG_BUILD_DIR)/
-       ln -sf /bin/true $(PKG_BUILD_DIR)/ltconfig
-endef
-
 define Build/Compile
        $(INSTALL_DIR) $(PKG_INSTALL_DIR)/usr/{include,lib,bin,man/man1}
        $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               LIBTOOL="./libtool --tag=CC" \
                prefix="$(PKG_INSTALL_DIR)/usr" \
                exec_prefix="$(PKG_INSTALL_DIR)/usr" \
                all install install-headers install-lib