Added support for most common USB serial adapters, closes #321
authorFlorian Fainelli <florian@openwrt.org>
Thu, 23 Feb 2006 16:53:45 +0000 (16:53 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 23 Feb 2006 16:53:45 +0000 (16:53 +0000)
SVN-Revision: 3268

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-usb-serial-belkin.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-usb-serial-ftdi.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-usb-serial-mct-u232.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-usb-serial-pl2303.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-usb-serial-visor.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-usb-serial.control
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/brcm

index 8a84ed36057791a3fe355ec0e7c96f11a09e78ec..233711dee65c7d251ac5285ce28d5b175aa91e27 100644 (file)
@@ -229,6 +229,31 @@ config BR2_PACKAGE_KMOD_USB_SERIAL
        default m 
        depends BR2_PACKAGE_KMOD_USB_CONTROLLER
 
+config BR2_PACKAGE_KMOD_USB_SERIAL_BELKIN
+       tristate "Support for Belkin USB-to-serial converters"
+       default m
+       depends BR2_PACKAGE_KMOD_USB_SERIAL
+       
+config BR2_PACKAGE_KMOD_USB_SERIAL_FTDI
+       tristate "Support for FTDI USB-to-serial converterr"
+       default m
+       depends BR2_PACKAGE_KMOD_USB_SERIAL
+
+config BR2_PACKAGE_KMOD_USB_SERIAL_MCT_U232
+        tristate "Support for Magic Control Technology USB-to-Serial converters"
+       default m
+       depends BR2_PACKAGE_KMOD_USB_SERIAL
+
+config BR2_PACKAGE_KMOD_USB_SERIAL_PL2303
+       tristate "Support for Prolific PL2303 USB-to-Serial converters"
+       default m
+       depends BR2_PACKAGE_KMOD_USB_SERIAL
+       
+config BR2_PACKAGE_KMOD_USB_SERIAL_VISOR
+       tristate "Support for Handspring Visor / Palm m50x / Sony Clie Driver"
+       default m
+       depends BR2_PACKAGE_KMOD_USB_SERIAL
+
 config BR2_PACKAGE_KMOD_USB_STORAGE
        tristate "Support for USB storage devices"
        default m
diff --git a/openwrt/target/linux/control/kmod-usb-serial-belkin.control b/openwrt/target/linux/control/kmod-usb-serial-belkin.control
new file mode 100644 (file)
index 0000000..708cc44
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-usb-serial-belkin
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for Belkin USB-to-Serial converters
diff --git a/openwrt/target/linux/control/kmod-usb-serial-ftdi.control b/openwrt/target/linux/control/kmod-usb-serial-ftdi.control
new file mode 100644 (file)
index 0000000..16bcdca
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-usb-serial-ftdi
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for FTDI USB-to-Serial converters
diff --git a/openwrt/target/linux/control/kmod-usb-serial-mct-u232.control b/openwrt/target/linux/control/kmod-usb-serial-mct-u232.control
new file mode 100644 (file)
index 0000000..00f2038
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-usb-serial-mct-u232
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for Magic Control Technology USB-to-Serial converters
diff --git a/openwrt/target/linux/control/kmod-usb-serial-pl2303.control b/openwrt/target/linux/control/kmod-usb-serial-pl2303.control
new file mode 100644 (file)
index 0000000..bccbdd8
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-usb-serial-pl2303
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for Prolific PL2303 USB-to-Serial converters
diff --git a/openwrt/target/linux/control/kmod-usb-serial-visor.control b/openwrt/target/linux/control/kmod-usb-serial-visor.control
new file mode 100644 (file)
index 0000000..7b993be
--- /dev/null
@@ -0,0 +1,7 @@
+Package: kmod-usb-serial-visor
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for Handspring Visor / Palm m50x / Sony Clie
+Driver
index d29a24236e54efaa725395f82bfb4dbfeb406bd0..dda5f9d01a3636566fef466b9690eabf58ec314f 100644 (file)
@@ -1,4 +1,6 @@
 Package: kmod-usb-serial
 Priority: optional
 Section: sys
-Description: Kernel modules for serial USB support
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for USB-to-Serial converters
index 1afe4d916ad7642458430197584914b4d1fff574..e1d970be38862a805f92b965c0356fed791d48ee 100644 (file)
@@ -139,6 +139,21 @@ $(eval $(call KMOD_template,USB_STORAGE,usb-storage,\
 $(eval $(call KMOD_template,USB_SERIAL,usb-serial,\
        $(MODULES_DIR)/kernel/drivers/usb/serial/*.o \
 ,CONFIG_USB_SERIAL,kmod-usb-core,60,usbserial))
+$(eval $(call KMOD_template,USB_SERIAL_BELKIN,usb-serial-belkin,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/belkin_sa.o \
+,CONFIG_USB_SERIAL_BELKIN,kmod-usb-serial,61,belkin_sa))
+$(eval $(call KMOD_template,USB_SERIAL_FTDI,usb-serial-ftdi,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/ftdi_sio.o \
+,CONFIG_USB_SERIAL_FTDI_SIO,kmod-usb-serial,61,ftdi_sio))
+$(eval $(call KMOD_template,USB_SERIAL_MCT_U232,usb-serial-mct-u232,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/mct_u232.o \
+,CONFIG_USB_SERIAL_MCT_U232,kmod-usb-serial,61,mct_u232))
+$(eval $(call KMOD_template,USB_SERIAL_PL2303,usb-serial-pl2303,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/pl2303.o \
+,CONFIG_USB_SERIAL_PL2303,kmod-usb-serial,61,pl2303))
+$(eval $(call KMOD_template,USB_SERIAL_VISOR,usb-serial-visor,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/visor.o \
+,CONFIG_USB_SERIAL_VISOR,kmod-usb-serial,61,visor))
 $(eval $(call KMOD_template,USB_PRINTER,usb-printer,\
        $(MODULES_DIR)/kernel/drivers/usb/printer.o \
 ,CONFIG_USB_PRINTER,kmod-usb-core,60,printer))
index a74fbbb7d5e0fd7135afc8a959ba63774eeba552..5e60fd0f8f119ef7fb87ae54bb26caae37b36d53 100644 (file)
@@ -1204,22 +1204,22 @@ CONFIG_USB_PWC=m
 CONFIG_USB_SERIAL=m
 # CONFIG_USB_SERIAL_DEBUG is not set
 CONFIG_USB_SERIAL_GENERIC=y
-# CONFIG_USB_SERIAL_BELKIN is not set
+CONFIG_USB_SERIAL_BELKIN=m
 # CONFIG_USB_SERIAL_WHITEHEAT is not set
 # CONFIG_USB_SERIAL_DIGI_ACCELEPORT is not set
 # CONFIG_USB_SERIAL_EMPEG is not set
-# CONFIG_USB_SERIAL_FTDI_SIO is not set
-# CONFIG_USB_SERIAL_VISOR is not set
+CONFIG_USB_SERIAL_FTDI_SIO=m
+CONFIG_USB_SERIAL_VISOR=m
 # CONFIG_USB_SERIAL_IPAQ is not set
 # CONFIG_USB_SERIAL_IR is not set
 # CONFIG_USB_SERIAL_EDGEPORT is not set
 # CONFIG_USB_SERIAL_EDGEPORT_TI is not set
 # CONFIG_USB_SERIAL_KEYSPAN_PDA is not set
 # CONFIG_USB_SERIAL_KEYSPAN is not set
-# CONFIG_USB_SERIAL_MCT_U232 is not set
+CONFIG_USB_SERIAL_MCT_U232=m
 # CONFIG_USB_SERIAL_KLSI is not set
 # CONFIG_USB_SERIAL_KOBIL_SCT is not set
-# CONFIG_USB_SERIAL_PL2303 is not set
+CONFIG_USB_SERIAL_PL2303=m
 # CONFIG_USB_SERIAL_CYBERJACK is not set
 # CONFIG_USB_SERIAL_XIRCOM is not set
 # CONFIG_USB_SERIAL_OMNINET is not set