compat: add install-ckmake target
authorLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 6 Jul 2012 20:05:27 +0000 (13:05 -0700)
committerLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 6 Jul 2012 20:05:27 +0000 (13:05 -0700)
Lets users quickly install ckmake onto /usr/bin/
with DESTDIR as an option target directory.

Signed-off-by: Luis R. Rodriguez <mcgrof@frijolero.org>
Makefile

index 05a7d7250ecaa5365e0b4f0dc0c635573cc1252e..cd4fc213a93e7b9f23df0506eb01698890a68a21 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -7,6 +7,8 @@ export KLIB:=          /lib/modules/$(shell uname -r)
 endif
 export KLIB_BUILD ?=    $(KLIB)/build
 
+DESTDIR?=
+
 ifeq ($(KERNELRELEASE),)
 export PWD := $(shell pwd)
 export COMPAT_BASE_TREE := "linux-next.git"
@@ -69,6 +71,10 @@ $(COMPAT_CONFIG):
 
 install: modules
 
+install-ckmake:
+       @mkdir -p $(DESTDIR)/usr/bin/
+       @install bin/ckmake $(DESTDIR)/usr/bin/
+
 clean:
        $(MAKE) -C $(KLIB_BUILD) M=$(PWD) clean