projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c5dfbea
)
ar71xx: ensure that LOADADDR is passed to lzma-loader
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 3 Jan 2016 20:57:16 +0000
(20:57 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 3 Jan 2016 20:57:16 +0000
(20:57 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48101
target/linux/ar71xx/image/lzma-loader/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/ar71xx/image/lzma-loader/Makefile
b/target/linux/ar71xx/image/lzma-loader/Makefile
index 2e0b9111f2894185a18cd506fbbe4049a02b65e1..9b81e87306f235d1e7284401828240b9b9787011 100644
(file)
--- a/
target/linux/ar71xx/image/lzma-loader/Makefile
+++ b/
target/linux/ar71xx/image/lzma-loader/Makefile
@@
-9,6
+9,7
@@
include $(TOPDIR)/rules.mk
LZMA_TEXT_START := 0x80a00000
+LOADADDR := 0x80060000
LOADER := loader.bin
LOADER_NAME := $(basename $(notdir $(LOADER)))
LOADER_DATA :=
@@
-38,6
+39,7
@@
$(PKG_BUILD_DIR)/.prepared:
loader-compile: $(PKG_BUILD_DIR)/.prepared
$(MAKE) -C $(PKG_BUILD_DIR) CROSS_COMPILE="$(TARGET_CROSS)" \
LZMA_TEXT_START=$(LZMA_TEXT_START) \
+ LOADADDR=$(LOADADDR) \
LOADER_DATA=$(LOADER_DATA) \
FLASH_OFFS=$(FLASH_OFFS) \
FLASH_MAX=$(FLASH_MAX) \