kernel: modules: video: fix imx-ldb
authorTim Harvey <tharvey@gateworks.com>
Mon, 20 May 2024 22:19:37 +0000 (15:19 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 6 Jun 2024 20:04:23 +0000 (22:04 +0200)
Commit ae8bf1a26e15 ("imx: add imx8m support") configured the
drm-imx-ldb kmod for imx_cortexa9 and imx_cortexa7 however it is only
applicable to imx_cortexa9 (imx6).

Fix this so that we can avoid a missing module config for cortexa7 when
moving to the 6.6 kernel.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
package/kernel/linux/modules/video.mk

index e242a06c42f3bf6b688f1ebd593a01fec1783fbb..ea5f82921ec65faff90d9b7b52ddb05226563edd 100644 (file)
@@ -460,7 +460,7 @@ $(eval $(call KernelPackage,drm-imx-hdmi))
 define KernelPackage/drm-imx-ldb
   SUBMENU:=$(VIDEO_MENU)
   TITLE:=Freescale i.MX LVDS DRM support
-  DEPENDS:=@(TARGET_imx&&!TARGET_imx_cortexa53) +kmod-backlight kmod-drm-imx
+  DEPENDS:=@(TARGET_imx&&TARGET_imx_cortexa9) +kmod-backlight kmod-drm-imx
   KCONFIG:=CONFIG_DRM_IMX_LDB \
        CONFIG_DRM_PANEL_SIMPLE \
        CONFIG_DRM_PANEL=y \