ppp: install pkg-config file on InstallDev
authorChristian Marangi <ansuelsmth@gmail.com>
Tue, 22 Oct 2024 14:10:05 +0000 (16:10 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 22 Oct 2024 14:10:05 +0000 (16:10 +0200)
It seems some package (sstp-client) makes use of pppd.pc file to detect
the ppp version as 2.5.0 changed some API.

Also install the .pc file to permit the version detection of pppd.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/network/services/ppp/Makefile

index 5f1ebd4e7d1bb7a792c690d7c21e9690f85b53c0..760a31dc0d02da617c8cc33501a8a9945adfc5a8 100644 (file)
@@ -192,6 +192,8 @@ endif
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/pppd $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig
 endef
 
 define Package/ppp/script_install