mediatek: MERCUSYS MR90X v1: add OpenWrt U-Boot (UBI) layout
authorMikhail Zhilkin <csharper2005@gmail.com>
Sun, 20 Oct 2024 12:21:33 +0000 (12:21 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 30 Nov 2024 17:36:05 +0000 (18:36 +0100)
This commit adds OpenWrt U-Boot (UBI) layout support for MERCUSYS MR90X
v1.

Stock U-Boot UBI size:   50 MiB
OpenWrt U-boot UBI size: 126 MiB

Install
-------
1. Perform steps 1-14 of the OpenWrt installation guide (use OpenWrt
   initramfs-recovery.itb instead of initramfs-kernel.bin at the step 10,
   12 and 14).
Link: https://openwrt.org/toh/mercusys/mr90x_v1#installation
2. Make backups:
```
cat /dev/mtd0 > /tmp/boot.bin
cat /dev/mtd5 > /tmp/tp_data.bin
```
   Copy /tp_data dir content, /tmp/boot.bin and /tmp/tp_data.bin and to
   your PC using scp. You can also backup the remaining partititons. Copy
   backups to a safe place, they are required for the next steps and stock
   firmware recovery.

3. Reboot to OpenWrt initramfs:
```
reboot
```

4. Copy OpenWrt ubi-bl31-uboot.fip, ubi-preloader.bin,
   ubi-squashfs-sysupgrade.itb and MT7986_EEPROM.bin, default-mac (from
   /tp_data backup) to the /tmp folder of the router using scp.

5. Prepare UBI:
```
ubidetach -p /dev/mtd3; ubiformat /dev/mtd3 -y; ubiattach -p /dev/mtd3
ubimkvol /dev/ubi0 -N fip -t static -s 1MiB
ubiupdatevol /dev/ubi0_0 /tmp/ubi-bl31-uboot.fip
ubimkvol /dev/ubi0 -N ubootenv -s 0x1f000
ubimkvol /dev/ubi0 -N ubootenv2 -s 0x1f000
```

6.  Install kmod-mtd-rw and unlock partitions:
```
opkg update && opkg install kmod-mtd-rw
insmod mtd-rw i_want_a_brick=1
mtd unlock boot
mtd unlock bl2
mtd unlock factory
```

7. Prepare "factory" partition:
```
dd if=/dev/zero bs=$((0x8000)) count=1 | tr '\000' '\377' > /tmp/factory.bin
dd if=/tmp/MT7986_EEPROM.bin of=/tmp/factory.bin conv=notrunc
dd if=/tmp/default-mac >> /tmp/factory.bin
```

8. Write "factory" partition:
```
mtd erase factory
mtd write /tmp/factory.bin factory
```

9. Write preloader partition:
```
mtd erase bl2
mtd write /tmp/ubi-preloader.bin bl2
```

10. Write OpenWrt sysupgrade image:
```
sysupgrade -n /tmp/ubi-squashfs-sysupgrade.itb
```

Recovery
--------
1. Place OpenWrt initramfs-recovery.itb image (with original name) on the
   tftp server (IP: 192.168.1.254).
2. Press "reset" button and power on the router. After ~10 sec release the
   button.
3. Use OpenWrt initramfs system for recovery.

BL2 and FIP recovery
--------------------
Use mtk_uartboot and UART connetion if BL2 or FIP in UBI is destroyed:
Link: https://github.com/981213/mtk_uartboot
Link: https://openwrt.org/toh/mercusys/mr90x_v1#serial
Return to stock:
----------------
1. Copy "boot" partition backup (boot.bin) to the /tmp dir of the router
   using scp.

2. Install kmod-mtd-rw:
```
opkg update && opkg install kmod-mtd-rw
```

3. Restore stock U-Boot:
```
   insmod mtd-rw i_want_a_brick=1
   mtd unlock boot
   mtd erase boot
   mtd write /tmp/boot.bin boot
```

4. Erase UBI and reboot:
```
mtd erase ubi
reboot
```

5. Open U-Boot web recovery, upload stock firmware image and start
   upgrade.
Link: http://192.168.1.1
6. Complete steps 1-9 of the OpenWrt installation guide to get root
   rights.
Link: https://openwrt.org/toh/mercusys/mr90x_v1#installation
7. Upload "tp_data" partition backup (tp_data.bin) to the /tmp folder of
   the router using scp.

8. Restore stock calibrations:
```
mtd write /tmp/tp_data.bin tp_data
reboot
```

9. Perform "factory restore" via stock firmware web interface.

Signed-off-by: Mikhail Zhilkin <csharper2005@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16744
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/uboot-envtools/files/mediatek_filogic
target/linux/mediatek/dts/mt7986b-mercusys-mr90x-v1-common.dtsi [new file with mode: 0644]
target/linux/mediatek/dts/mt7986b-mercusys-mr90x-v1-ubi.dts [new file with mode: 0644]
target/linux/mediatek/dts/mt7986b-mercusys-mr90x-v1.dts
target/linux/mediatek/filogic/base-files/etc/board.d/01_leds
target/linux/mediatek/filogic/base-files/etc/board.d/02_network
target/linux/mediatek/filogic/base-files/lib/upgrade/platform.sh
target/linux/mediatek/image/filogic.mk

index 58db7dad281c0c6f5ded7a196c3c8113c32d1262..5bde699a47a47d2f160ba0a02103ef00e88761ec 100644 (file)
@@ -36,6 +36,7 @@ case "$board" in
 abt,asr3000|\
 h3c,magic-nx30-pro|\
 jcg,q30-pro|\
+mercusys,mr90x-v1-ubi|\
 netcore,n60|\
 nokia,ea0326gmp|\
 qihoo,360t7|\
diff --git a/target/linux/mediatek/dts/mt7986b-mercusys-mr90x-v1-common.dtsi b/target/linux/mediatek/dts/mt7986b-mercusys-mr90x-v1-common.dtsi
new file mode 100644 (file)
index 0000000..5522c58
--- /dev/null
@@ -0,0 +1,252 @@
+// SPDX-License-Identifier: (GL-2.0 OR MIT)
+
+/dts-v1/;
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/leds/common.h>
+
+#include "mt7986b.dtsi"
+
+/ {
+       aliases: aliases {
+               led-boot = &led_status_green;
+               led-failsafe = &led_status_green;
+               led-running = &led_status_green;
+               led-upgrade = &led_status_green;
+
+               serial0 = &uart0;
+       };
+
+       chosen: chosen {
+               stdout-path = "serial0:115200n8";
+       };
+
+       memory {
+               reg = <0 0x40000000 0 0x20000000>;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&pio 10 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led-0 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_LAN;
+                       function-enumerator = <2>;
+                       gpios = <&pio 7 GPIO_ACTIVE_LOW>;
+               };
+
+               led-1 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_LAN;
+                       function-enumerator = <1>;
+                       gpios = <&pio 9 GPIO_ACTIVE_LOW>;
+               };
+
+               led-2 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_LAN;
+                       function-enumerator = <0>;
+                       gpios = <&pio 12 GPIO_ACTIVE_LOW>;
+               };
+
+               led-3 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_WAN;
+                       gpios = <&pio 13 GPIO_ACTIVE_LOW>;
+               };
+
+               led-4 {
+                       color = <LED_COLOR_ID_AMBER>;
+                       function = LED_FUNCTION_STATUS;
+                       gpios = <&pio 16 GPIO_ACTIVE_HIGH>;
+                       panic-indicator;
+               };
+
+               led_status_green: led-5 {
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_STATUS;
+                       gpios = <&pio 17 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&crypto {
+       status = "okay";
+};
+
+&eth {
+       status = "okay";
+
+       gmac0: mac@0 {
+               compatible = "mediatek,eth-mac";
+               reg = <0>;
+               phy-mode = "2500base-x";
+
+               fixed-link {
+                       speed = <2500>;
+                       full-duplex;
+                       pause;
+               };
+       };
+
+       gmac1: mac@1 {
+               compatible = "mediatek,eth-mac";
+               reg = <1>;
+               phy-handle = <&phy6>;
+               phy-mode = "2500base-x";
+       };
+
+       mdio: mdio-bus {
+               #address-cells = <1>;
+               #size-cells = <0>;
+       };
+};
+
+&mdio {
+       #address-cells = <1>;
+       #size-cells = <0>;
+
+       reset-gpios = <&pio 6 GPIO_ACTIVE_LOW>;
+       reset-delay-us = <1500000>;
+       reset-post-delay-us = <1000000>;
+
+       /* WAN/LAN 2.5Gbps phy
+          MaxLinear GPY211C0VC (SLNW8) */
+       phy6: phy@6 {
+               compatible = "ethernet-phy-ieee802.3-c45";
+               reg = <6>;
+       };
+
+       switch: switch@1f {
+               compatible = "mediatek,mt7531";
+               reg = <31>;
+               reset-gpios = <&pio 5 GPIO_ACTIVE_HIGH>;
+       };
+};
+
+&switch {
+       ports {
+               #address-cells = <1>;
+               #size-cells = <0>;
+
+               /* WAN/LAN 1Gbps port */
+               port@0 {
+                       reg = <0>;
+                       label = "lan0";
+               };
+
+               /* LAN1 port */
+               port@1 {
+                       reg = <1>;
+                       label = "lan1";
+               };
+
+               /* LAN2 port */
+               port@2 {
+                       reg = <2>;
+                       label = "lan2";
+               };
+
+               port@6 {
+                       reg = <6>;
+                       ethernet = <&gmac0>;
+                       phy-mode = "2500base-x";
+
+                       fixed-link {
+                               speed = <2500>;
+                               full-duplex;
+                               pause;
+                       };
+               };
+       };
+};
+
+&pio {
+       spi_flash_pins: spi-flash-pins-33-to-38 {
+               mux {
+                       function = "spi";
+                       groups = "spi0", "spi0_wp_hold";
+               };
+               conf-pu {
+                       pins = "SPI2_CS", "SPI2_HOLD", "SPI2_WP";
+                       drive-strength = <8>;
+                       mediatek,pull-up-adv = <0>; /* bias-disable */
+               };
+               conf-pd {
+                       pins = "SPI2_CLK", "SPI2_MOSI", "SPI2_MISO";
+                       drive-strength = <8>;
+                       mediatek,pull-down-adv = <0>; /* bias-disable */
+               };
+       };
+
+       wf_2g_5g_pins: wf_2g_5g-pins {
+               mux {
+                       function = "wifi";
+                       groups = "wf_2g", "wf_5g";
+               };
+               conf {
+                       pins = "WF0_HB1", "WF0_HB2", "WF0_HB3", "WF0_HB4",
+                              "WF0_HB0", "WF0_HB0_B", "WF0_HB5", "WF0_HB6",
+                              "WF0_HB7", "WF0_HB8", "WF0_HB9", "WF0_HB10",
+                              "WF0_TOP_CLK", "WF0_TOP_DATA", "WF1_HB1",
+                              "WF1_HB2", "WF1_HB3", "WF1_HB4", "WF1_HB0",
+                              "WF1_HB5", "WF1_HB6", "WF1_HB7", "WF1_HB8",
+                              "WF1_TOP_CLK", "WF1_TOP_DATA";
+                       drive-strength = <4>;
+               };
+       };
+};
+
+&spi0 {
+       pinctrl-names = "default";
+       pinctrl-0 = <&spi_flash_pins>;
+       status = "okay";
+
+       spi_nand_flash: flash@0 {
+               compatible = "spi-nand";
+               #address-cells = <1>;
+               #size-cells = <1>;
+               reg = <0>;
+
+               spi-max-frequency = <20000000>;
+               spi-tx-bus-width = <4>;
+               spi-rx-bus-width = <4>;
+
+               partitions: partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+               };
+       };
+};
+
+&trng {
+       status = "okay";
+};
+
+&uart0 {
+       status = "okay";
+};
+
+&watchdog {
+       status = "okay";
+};
+
+&wifi {
+       status = "okay";
+
+       pinctrl-names = "default";
+       pinctrl-0 = <&wf_2g_5g_pins>;
+
+       ieee80211-freq-limit = <2400000 2500000>, <5170000 5835000>;
+};
diff --git a/target/linux/mediatek/dts/mt7986b-mercusys-mr90x-v1-ubi.dts b/target/linux/mediatek/dts/mt7986b-mercusys-mr90x-v1-ubi.dts
new file mode 100644 (file)
index 0000000..cfa1950
--- /dev/null
@@ -0,0 +1,124 @@
+// SPDX-License-Identifier: (GL-2.0 OR MIT)
+
+#include "mt7986b-mercusys-mr90x-v1-common.dtsi"
+
+/ {
+       compatible = "mercusys,mr90x-v1-ubi", "mediatek,mt7986b";
+       model = "MERCUSYS MR90X v1 (UBI)";
+};
+
+&aliases {
+       label-mac-device = &gmac0;
+};
+
+&chosen {
+       bootargs-append = " root=/dev/fit0 rootwait";
+       rootdisk = <&ubi_fit>;
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_factory_8000 0>;
+       nvmem-cell-names = "mac-address";
+};
+
+&gmac1 {
+       nvmem-cells = <&macaddr_factory_8000 1>;
+       nvmem-cell-names = "mac-address";
+};
+
+&partitions {
+       partition@0 {
+               label = "boot";
+               reg = <0x0 0x200000>;
+               read-only;
+
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "bl2";
+                       reg = <0x0 0x100000>;
+                       read-only;
+               };
+
+               partition@100000 {
+                       label = "factory";
+                       reg = <0x100000 0x100000>;
+                       read-only;
+
+                       nvmem-layout {
+                               compatible = "fixed-layout";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               eeprom_factory_0: eeprom@0 {
+                                       reg = <0x0 0x1000>;
+                               };
+
+                               macaddr_factory_8000: macaddr@8000 {
+                                       compatible = "mac-base";
+                                       reg = <0x8000 0x6>;
+                                       #nvmem-cell-cells = <1>;
+                               };
+                       };
+               };
+       };
+
+       partition@200000 {
+               compatible = "linux,ubi";
+               reg = <0x200000 0x7e00000>;
+               label = "ubi";
+
+               volumes {
+                       ubi_fit: ubi-volume-fit {
+                               volname = "fit";
+                       };
+
+                       ubi_ubootenv: ubi-volume-ubootenv {
+                               volname = "ubootenv";
+                       };
+
+                       ubi_ubootenv2: ubi-volume-ubootenv2 {
+                               volname = "ubootenv2";
+                       };
+               };
+       };
+};
+
+&trng {
+       status = "okay";
+};
+
+&uart0 {
+       status = "okay";
+};
+
+&ubi_ubootenv {
+       nvmem-layout {
+               compatible = "u-boot,env-redundant-bool";
+       };
+};
+
+&ubi_ubootenv2 {
+       nvmem-layout {
+               compatible = "u-boot,env-redundant-bool";
+       };
+};
+
+&wifi {
+       nvmem-cells = <&eeprom_factory_0>;
+       nvmem-cell-names = "eeprom";
+
+       band@0 {
+               reg = <0>;
+               nvmem-cells = <&macaddr_factory_8000 0>;
+               nvmem-cell-names = "mac-address";
+       };
+
+       band@1 {
+               reg = <1>;
+               nvmem-cells = <&macaddr_factory_8000 (-1)>;
+               nvmem-cell-names = "mac-address";
+       };
+};
index f0a995820ec1a43428f44a0ef454500deeed7d7c..16d890a3933531c34288efe092bd11f48c996aed 100644 (file)
 // SPDX-License-Identifier: (GL-2.0 OR MIT)
 
-/dts-v1/;
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/leds/common.h>
-
-#include "mt7986b.dtsi"
+#include "mt7986b-mercusys-mr90x-v1-common.dtsi"
 
 / {
        compatible = "mercusys,mr90x-v1", "mediatek,mt7986b";
        model = "MERCUSYS MR90X v1";
-
-       aliases {
-               serial0 = &uart0;
-
-               led-boot = &led_status_green;
-               led-failsafe = &led_status_green;
-               led-running = &led_status_green;
-               led-upgrade = &led_status_green;
-       };
-
-       chosen {
-               stdout-path = "serial0:115200n8";
-       };
-
-       memory {
-               reg = <0 0x40000000 0 0x20000000>;
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&pio 10 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led-0 {
-                       color = <LED_COLOR_ID_GREEN>;
-                       function = LED_FUNCTION_LAN;
-                       function-enumerator = <2>;
-                       gpios = <&pio 7 GPIO_ACTIVE_LOW>;
-               };
-
-               led-1 {
-                       color = <LED_COLOR_ID_GREEN>;
-                       function = LED_FUNCTION_LAN;
-                       function-enumerator = <1>;
-                       gpios = <&pio 9 GPIO_ACTIVE_LOW>;
-               };
-
-               led-2 {
-                       color = <LED_COLOR_ID_GREEN>;
-                       function = LED_FUNCTION_LAN;
-                       function-enumerator = <0>;
-                       gpios = <&pio 12 GPIO_ACTIVE_LOW>;
-               };
-
-               led-3 {
-                       color = <LED_COLOR_ID_GREEN>;
-                       function = LED_FUNCTION_WAN;
-                       gpios = <&pio 13 GPIO_ACTIVE_LOW>;
-               };
-
-               led-4 {
-                       color = <LED_COLOR_ID_AMBER>;
-                       function = LED_FUNCTION_STATUS;
-                       gpios = <&pio 16 GPIO_ACTIVE_HIGH>;
-                       panic-indicator;
-               };
-
-               led_status_green: led-5 {
-                       color = <LED_COLOR_ID_GREEN>;
-                       function = LED_FUNCTION_STATUS;
-                       gpios = <&pio 17 GPIO_ACTIVE_HIGH>;
-               };
-       };
 };
 
-&crypto {
-       status = "okay";
-};
-
-&eth {
-       status = "okay";
-
-       gmac0: mac@0 {
-               compatible = "mediatek,eth-mac";
-               reg = <0>;
-               phy-mode = "2500base-x";
-
-               fixed-link {
-                       speed = <2500>;
-                       full-duplex;
-                       pause;
-               };
+&partitions {
+       partition@0 {
+               label = "boot";
+               reg = <0x0 0x200000>;
+               read-only;
        };
 
-       gmac1: mac@1 {
-               compatible = "mediatek,eth-mac";
-               reg = <1>;
-               phy-handle = <&phy6>;
-               phy-mode = "2500base-x";
+       partition@200000 {
+               label = "u-boot-env";
+               reg = <0x200000 0x100000>;
        };
 
-       mdio: mdio-bus {
-               #address-cells = <1>;
-               #size-cells = <0>;
+       partition@300000 {
+               label = "ubi0";
+               reg = <0x300000 0x3200000>;
        };
-};
-
-&mdio {
-       #address-cells = <1>;
-       #size-cells = <0>;
-
-       reset-gpios = <&pio 6 GPIO_ACTIVE_LOW>;
-       reset-delay-us = <1500000>;
-       reset-post-delay-us = <1000000>;
 
-       /* WAN/LAN 2.5Gbps phy
-          MaxLinear GPY211C0VC (SLNW8) */
-       phy6: phy@6 {
-               compatible = "ethernet-phy-ieee802.3-c45";
-               reg = <6>;
+       partition@3500000 {
+               label = "ubi1";
+               reg = <0x3500000 0x3200000>;
+               read-only;
        };
 
-       switch: switch@1f {
-               compatible = "mediatek,mt7531";
-               reg = <31>;
-               reset-gpios = <&pio 5 GPIO_ACTIVE_HIGH>;
+       partition@6700000 {
+               label = "userconfig";
+               reg = <0x6700000 0x800000>;
+               read-only;
        };
-};
-
-&switch {
-       ports {
-               #address-cells = <1>;
-               #size-cells = <0>;
-
-               /* WAN/LAN 1Gbps port */
-               port@0 {
-                       reg = <0>;
-                       label = "lan0";
-               };
 
-               /* LAN1 port */
-               port@1 {
-                       reg = <1>;
-                       label = "lan1";
-               };
-
-               /* LAN2 port */
-               port@2 {
-                       reg = <2>;
-                       label = "lan2";
-               };
-
-               port@6 {
-                       reg = <6>;
-                       ethernet = <&gmac0>;
-                       phy-mode = "2500base-x";
-
-                       fixed-link {
-                               speed = <2500>;
-                               full-duplex;
-                               pause;
-                       };
-               };
-       };
-};
-
-&pio {
-       spi_flash_pins: spi-flash-pins-33-to-38 {
-               mux {
-                       function = "spi";
-                       groups = "spi0", "spi0_wp_hold";
-               };
-               conf-pu {
-                       pins = "SPI2_CS", "SPI2_HOLD", "SPI2_WP";
-                       drive-strength = <8>;
-                       mediatek,pull-up-adv = <0>; /* bias-disable */
-               };
-               conf-pd {
-                       pins = "SPI2_CLK", "SPI2_MOSI", "SPI2_MISO";
-                       drive-strength = <8>;
-                       mediatek,pull-down-adv = <0>; /* bias-disable */
-               };
-       };
-
-       wf_2g_5g_pins: wf_2g_5g-pins {
-               mux {
-                       function = "wifi";
-                       groups = "wf_2g", "wf_5g";
-               };
-               conf {
-                       pins = "WF0_HB1", "WF0_HB2", "WF0_HB3", "WF0_HB4",
-                              "WF0_HB0", "WF0_HB0_B", "WF0_HB5", "WF0_HB6",
-                              "WF0_HB7", "WF0_HB8", "WF0_HB9", "WF0_HB10",
-                              "WF0_TOP_CLK", "WF0_TOP_DATA", "WF1_HB1",
-                              "WF1_HB2", "WF1_HB3", "WF1_HB4", "WF1_HB0",
-                              "WF1_HB5", "WF1_HB6", "WF1_HB7", "WF1_HB8",
-                              "WF1_TOP_CLK", "WF1_TOP_DATA";
-                       drive-strength = <4>;
-               };
-       };
-};
-
-&spi0 {
-       pinctrl-names = "default";
-       pinctrl-0 = <&spi_flash_pins>;
-       status = "okay";
-
-       spi_nand_flash: flash@0 {
-               compatible = "spi-nand";
-               #address-cells = <1>;
-               #size-cells = <1>;
-               reg = <0>;
-
-               spi-max-frequency = <20000000>;
-               spi-tx-bus-width = <4>;
-               spi-rx-bus-width = <4>;
-
-               partitions: partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "boot";
-                               reg = <0x0 0x200000>;
-                               read-only;
-                       };
-
-                       partition@200000 {
-                               label = "u-boot-env";
-                               reg = <0x200000 0x100000>;
-                       };
-
-                       partition@300000 {
-                               label = "ubi0";
-                               reg = <0x300000 0x3200000>;
-                       };
-
-                       partition@3500000 {
-                               label = "ubi1";
-                               reg = <0x3500000 0x3200000>;
-                               read-only;
-                       };
-
-                       partition@6700000 {
-                               label = "userconfig";
-                               reg = <0x6700000 0x800000>;
-                               read-only;
-                       };
-
-                       partition@6f00000 {
-                               label = "tp_data";
-                               reg = <0x6f00000 0x400000>;
-                               read-only;
-                       };
-               };
+       partition@6f00000 {
+               label = "tp_data";
+               reg = <0x6f00000 0x400000>;
+               read-only;
        };
 };
-
-&trng {
-       status = "okay";
-};
-
-&uart0 {
-       status = "okay";
-};
-
-&watchdog {
-       status = "okay";
-};
-
-&wifi {
-       status = "okay";
-       pinctrl-names = "default";
-       pinctrl-0 = <&wf_2g_5g_pins>;
-};
index 38c4b7525b60e75d941bdde6980a6caf5ac5e2b2..64df50eb0a18e894276a1c421e4e1291b91f1153 100644 (file)
@@ -49,7 +49,8 @@ glinet,gl-xe3000)
        ucidef_set_led_netdev "wlan2g" "WLAN2G" "green:wifi2g" "phy0-ap0"
        ucidef_set_led_netdev "wlan5g" "WLAN5G" "green:wifi5g" "phy1-ap0"
        ;;
-mercusys,mr90x-v1)
+mercusys,mr90x-v1|\
+mercusys,mr90x-v1-ubi)
        ucidef_set_led_netdev "lan-0" "lan-0" "green:lan-0" "lan0" "link tx rx"
        ucidef_set_led_netdev "lan-1" "lan-1" "green:lan-1" "lan1" "link tx rx"
        ucidef_set_led_netdev "lan-2" "lan-2" "green:lan-2" "lan2" "link tx rx"
index 953d96d09c5de90afda296474bbae4d42e5cd012..ba785644022cdfb17cd64b6b55a5135edb64ffa1 100644 (file)
@@ -106,7 +106,8 @@ mediatek_setup_interfaces()
        mediatek,mt7988a-rfb)
                ucidef_set_interfaces_lan_wan "lan0 lan1 lan2 lan3 eth2" eth1
                ;;
-       mercusys,mr90x-v1)
+       mercusys,mr90x-v1|\
+       mercusys,mr90x-v1-ubi)
                ucidef_set_interfaces_lan_wan "lan0 lan1 lan2" eth1
                ;;
        tplink,tl-xdr6086|\
index 0040ffbb266627eb7edee43b133de15e918e024d..fb48ffc49f090dd8a168fea0959d1f8c914754c9 100755 (executable)
@@ -76,6 +76,7 @@ platform_do_upgrade() {
        jdcloud,re-cp-03|\
        mediatek,mt7981-rfb|\
        mediatek,mt7988a-rfb|\
+       mercusys,mr90x-v1-ubi|\
        nokia,ea0326gmp|\
        openwrt,one|\
        netcore,n60|\
index ddd23f4d640a4a0ce03d6c9f9c2ed67fc53dde53..5498922f6edf6befe042159531c78bdfc9a3761a 100644 (file)
@@ -1079,6 +1079,34 @@ define Device/mercusys_mr90x-v1
 endef
 TARGET_DEVICES += mercusys_mr90x-v1
 
+define Device/mercusys_mr90x-v1-ubi
+  DEVICE_VENDOR := MERCUSYS
+  DEVICE_MODEL := MR90X v1 (UBI)
+  DEVICE_DTS := mt7986b-mercusys-mr90x-v1-ubi
+  DEVICE_DTS_DIR := ../dts
+  DEVICE_DTC_FLAGS := --pad 4096
+  DEVICE_DTS_LOADADDR := 0x43f00000
+  DEVICE_PACKAGES := kmod-mt7915e kmod-mt7986-firmware mt7986-wo-firmware
+  UBINIZE_OPTS := -E 5
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  KERNEL_IN_UBI := 1
+  UBOOTENV_IN_UBI := 1
+  IMAGES := sysupgrade.itb
+  KERNEL_INITRAMFS_SUFFIX := -recovery.itb
+  KERNEL := kernel-bin | gzip
+  KERNEL_INITRAMFS := kernel-bin | lzma | \
+       fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | \
+       pad-to 64k
+  IMAGE/sysupgrade.itb := append-kernel | \
+       fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb external-with-rootfs | \
+       append-metadata
+  ARTIFACTS := bl31-uboot.fip preloader.bin
+  ARTIFACT/bl31-uboot.fip := mt7986-bl31-uboot mercusys_mr90x-v1
+  ARTIFACT/preloader.bin := mt7986-bl2 spim-nand-ubi-ddr3
+endef
+TARGET_DEVICES += mercusys_mr90x-v1-ubi
+
 define Device/netcore_n60
   DEVICE_VENDOR := Netcore
   DEVICE_MODEL := N60