add ath5k tracing fix
authorJohannes Berg <johannes@sipsolutions.net>
Mon, 1 Apr 2013 21:34:53 +0000 (23:34 +0200)
committerJohannes Berg <johannes@sipsolutions.net>
Mon, 1 Apr 2013 21:34:53 +0000 (23:34 +0200)
Signed-off-by: Johannes Berg <johannes@sipsolutions.net>
patches/collateral-evolutions/network/73-ath5k-tracing/INFO [new file with mode: 0644]
patches/collateral-evolutions/network/73-ath5k-tracing/ath5k.patch [new file with mode: 0644]

diff --git a/patches/collateral-evolutions/network/73-ath5k-tracing/INFO b/patches/collateral-evolutions/network/73-ath5k-tracing/INFO
new file mode 100644 (file)
index 0000000..038272b
--- /dev/null
@@ -0,0 +1,11 @@
+ath5k tracing uses
+
+#define TRACE_INCLUDE_PATH ../../drivers/net/wireless/ath/ath5k
+
+This is problematic because it means that if you build the
+backported modules against a full kernel tree the build
+uses the original trace.h, not the one from backport, and
+this fails (due to the config symbol mangling, but it's more
+generally an issue)
+
+Fix this by doing the same all other drivers do.
diff --git a/patches/collateral-evolutions/network/73-ath5k-tracing/ath5k.patch b/patches/collateral-evolutions/network/73-ath5k-tracing/ath5k.patch
new file mode 100644 (file)
index 0000000..1adb3f9
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/drivers/net/wireless/ath/ath5k/trace.h
++++ b/drivers/net/wireless/ath/ath5k/trace.h
+@@ -97,7 +97,7 @@ TRACE_EVENT(ath5k_tx_complete,
+ #if defined(CONFIG_ATH5K_TRACER) && !defined(__CHECKER__)
+ #undef TRACE_INCLUDE_PATH
+-#define TRACE_INCLUDE_PATH ../../drivers/net/wireless/ath/ath5k
++#define TRACE_INCLUDE_PATH .
+ #undef TRACE_INCLUDE_FILE
+ #define TRACE_INCLUDE_FILE trace
+--- a/drivers/net/wireless/ath/ath5k/Makefile
++++ b/drivers/net/wireless/ath/ath5k/Makefile
+@@ -10,6 +10,7 @@ ath5k-y                              += phy.o
+ ath5k-y                               += reset.o
+ ath5k-y                               += attach.o
+ ath5k-y                               += base.o
++CFLAGS_base.o                 += -I$(src)
+ ath5k-y                               += led.o
+ ath5k-y                               += rfkill.o
+ ath5k-y                               += ani.o