projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2650e7a
)
kernel: kmod-can-usb-esd: Fix build on kernel 6.6
author
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 26 May 2024 20:24:59 +0000
(22:24 +0200)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Tue, 28 May 2024 20:07:43 +0000
(22:07 +0200)
The kernel module and configuration option was renamed from esd_usb2.ko
to esd_usb.ko in kernel 6.0. Adapt the kernel package.
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=
5e910bdedc84c1f196863cebdf27c1806449c27c
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/can.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/can.mk
b/package/kernel/linux/modules/can.mk
index eda9b0c48784455e8bf50e0ecc2ba40784dec433..603976ef5f10fff38e01398afbe5c245b2425fb2 100644
(file)
--- a/
package/kernel/linux/modules/can.mk
+++ b/
package/kernel/linux/modules/can.mk
@@
-235,9
+235,13
@@
$(eval $(call KernelPackage,can-usb-ems))
define KernelPackage/can-usb-esd
TITLE:=ESD USB/2 CAN/USB interface
- KCONFIG:=CONFIG_CAN_ESD_USB2
- FILES:=$(LINUX_DIR)/drivers/net/can/usb/esd_usb2.ko
- AUTOLOAD:=$(call AutoProbe,esd_usb2)
+ KCONFIG:= \
+ CONFIG_CAN_ESD_USB2@lt6.0 \
+ CONFIG_CAN_ESD_USB@ge6.0
+ FILES:= \
+ $(LINUX_DIR)/drivers/net/can/usb/esd_usb2.ko@lt6.0 \
+ $(LINUX_DIR)/drivers/net/can/usb/esd_usb.ko@ge6.0
+ AUTOLOAD:=$(call AutoProbe,esd_usb2 esd_usb)
$(call AddDepends/can,+kmod-usb-core)
endef