---- a/drivers/mtd/maps/physmap.c
-+++ b/drivers/mtd/maps/physmap.c
-@@ -78,7 +78,7 @@ static const char *rom_probe_types[] = {
- "map_rom",
- NULL };
- static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "afs",
-- NULL };
-+ "ar7part", NULL };
-
- static int physmap_flash_probe(struct platform_device *dev)
- {
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
@@ -10,7 +10,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
--- a/arch/mips/ar7/platform.c
+++ b/arch/mips/ar7/platform.c
-@@ -199,7 +199,7 @@ static struct resource physmap_flash_res
+@@ -199,11 +199,14 @@ static struct resource physmap_flash_res
.name = "mem",
.flags = IORESOURCE_MEM,
.start = 0x10000000,
+ .end = 0x11ffffff,
};
++static const char *ar7_probe_types[] = { "ar7part", NULL };
++
static struct physmap_flash_data physmap_flash_data = {
+ .width = 2,
++ .part_probe_types = ar7_probe_types,
+ };
+
+ static struct platform_device physmap_flash = {
---- a/drivers/mtd/maps/physmap.c
-+++ b/drivers/mtd/maps/physmap.c
-@@ -78,7 +78,7 @@ static const char *rom_probe_types[] = {
- "map_rom",
- NULL };
- static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "afs",
-- "ar7part", NULL };
-+ "ac49xpart", "ar7part", NULL };
-
- static int physmap_flash_probe(struct platform_device *dev)
- {
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
@@ -143,6 +143,11 @@ config MTD_OF_PARTS
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+--- a/arch/mips/ar7/platform.c
++++ b/arch/mips/ar7/platform.c
+@@ -202,7 +202,7 @@ static struct resource physmap_flash_res
+ .end = 0x11ffffff,
+ };
+
+-static const char *ar7_probe_types[] = { "ar7part", NULL };
++static const char *ar7_probe_types[] = { "ac49xpart", "ar7part", NULL };
+
+ static struct physmap_flash_data physmap_flash_data = {
+ .width = 2,
--- a/arch/mips/ar7/platform.c
+++ b/arch/mips/ar7/platform.c
-@@ -462,31 +462,22 @@ static struct gpio_led fb_fon_leds[] = {
+@@ -465,31 +465,22 @@ static struct gpio_led fb_fon_leds[] = {
},
};
.default_trigger = "default-on",
},
{
-@@ -494,6 +485,44 @@ static struct gpio_led gt701_leds[] = {
+@@ -497,6 +488,44 @@ static struct gpio_led gt701_leds[] = {
.gpio = 10,
.active_low = 1,
},
};
static struct gpio_led_platform_data ar7_led_data;
-@@ -537,9 +566,9 @@ static void __init detect_leds(void)
+@@ -540,9 +569,9 @@ static void __init detect_leds(void)
} else if (strstr(prid, "CYWM") || strstr(prid, "CYWL")) {
ar7_led_data.num_leds = ARRAY_SIZE(titan_leds);
ar7_led_data.leds = titan_leds;
--- a/arch/mips/ar7/platform.c
+++ b/arch/mips/ar7/platform.c
-@@ -709,26 +709,23 @@ static int __init ar7_register_devices(v
+@@ -712,26 +712,23 @@ static int __init ar7_register_devices(v
}
if (ar7_has_high_cpmac()) {
detect_leds();
res = platform_device_register(&ar7_gpio_leds);
-@@ -741,8 +738,10 @@ static int __init ar7_register_devices(v
+@@ -744,8 +741,10 @@ static int __init ar7_register_devices(v
/* Register watchdog only if enabled in hardware */
bootcr = ioremap_nocache(AR7_REGS_DCL, 4);
---- a/drivers/mtd/maps/physmap.c
-+++ b/drivers/mtd/maps/physmap.c
-@@ -94,7 +94,7 @@ static const char *rom_probe_types[] = {
- "map_rom",
- NULL };
- static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "afs",
-- NULL };
-+ "ar7part", NULL };
-
- static int physmap_flash_probe(struct platform_device *dev)
- {
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
@@ -10,7 +10,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
--- a/arch/mips/ar7/platform.c
+++ b/arch/mips/ar7/platform.c
-@@ -199,7 +199,7 @@ static struct resource physmap_flash_res
+@@ -199,11 +199,14 @@ static struct resource physmap_flash_res
.name = "mem",
.flags = IORESOURCE_MEM,
.start = 0x10000000,
+ .end = 0x11ffffff,
};
++static const char *ar7_probe_types[] = { "ar7part", NULL };
++
static struct physmap_flash_data physmap_flash_data = {
+ .width = 2,
++ .part_probe_types = ar7_probe_types,
+ };
+
+ static struct platform_device physmap_flash = {
---- a/drivers/mtd/maps/physmap.c
-+++ b/drivers/mtd/maps/physmap.c
-@@ -94,7 +94,7 @@ static const char *rom_probe_types[] = {
- "map_rom",
- NULL };
- static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "afs",
-- "ar7part", NULL };
-+ "ac49xpart", "ar7part", NULL };
-
- static int physmap_flash_probe(struct platform_device *dev)
- {
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
@@ -143,6 +143,11 @@ config MTD_OF_PARTS
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+--- a/arch/mips/ar7/platform.c
++++ b/arch/mips/ar7/platform.c
+@@ -202,7 +202,7 @@ static struct resource physmap_flash_res
+ .end = 0x11ffffff,
+ };
+
+-static const char *ar7_probe_types[] = { "ar7part", NULL };
++static const char *ar7_probe_types[] = { "ac49xpart", "ar7part", NULL };
+
+ static struct physmap_flash_data physmap_flash_data = {
+ .width = 2,
--- a/arch/mips/ar7/platform.c
+++ b/arch/mips/ar7/platform.c
-@@ -462,31 +462,22 @@ static struct gpio_led fb_fon_leds[] = {
+@@ -465,31 +465,22 @@ static struct gpio_led fb_fon_leds[] = {
},
};
.default_trigger = "default-on",
},
{
-@@ -494,6 +485,44 @@ static struct gpio_led gt701_leds[] = {
+@@ -497,6 +488,44 @@ static struct gpio_led gt701_leds[] = {
.gpio = 10,
.active_low = 1,
},
};
static struct gpio_led_platform_data ar7_led_data;
-@@ -537,9 +566,9 @@ static void __init detect_leds(void)
+@@ -540,9 +569,9 @@ static void __init detect_leds(void)
} else if (strstr(prid, "CYWM") || strstr(prid, "CYWL")) {
ar7_led_data.num_leds = ARRAY_SIZE(titan_leds);
ar7_led_data.leds = titan_leds;
--- a/arch/mips/ar7/platform.c
+++ b/arch/mips/ar7/platform.c
-@@ -709,26 +709,23 @@ static int __init ar7_register_devices(v
+@@ -712,26 +712,23 @@ static int __init ar7_register_devices(v
}
if (ar7_has_high_cpmac()) {
detect_leds();
res = platform_device_register(&ar7_gpio_leds);
-@@ -741,8 +738,10 @@ static int __init ar7_register_devices(v
+@@ -744,8 +741,10 @@ static int __init ar7_register_devices(v
/* Register watchdog only if enabled in hardware */
bootcr = ioremap_nocache(AR7_REGS_DCL, 4);