projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
45462e9
)
kernel/modules: use crc32c_generic.ko instead of crc32c.ko
author
John Crispin
<john@openwrt.org>
Mon, 17 Nov 2014 14:30:42 +0000
(14:30 +0000)
committer
John Crispin
<john@openwrt.org>
Mon, 17 Nov 2014 14:30:42 +0000
(14:30 +0000)
Starting from kernel version 3.15, the crc32c module was renamed to
crc32c_generic.
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 43291
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index efa69b7590b7deedf1025b15e25a09d64ec56474..e0a2e2725674d7e30945ab348af0697c0692dde4 100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-299,8
+299,13
@@
define KernelPackage/crypto-crc32c
TITLE:=CRC32c CRC module
DEPENDS:=+kmod-crypto-hash
KCONFIG:=CONFIG_CRYPTO_CRC32C
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.15.0)),1)
+ FILES:=$(LINUX_DIR)/crypto/crc32c_generic.ko
+ AUTOLOAD:=$(call AutoLoad,04,crc32c_generic,1)
+else
FILES:=$(LINUX_DIR)/crypto/crc32c.ko
AUTOLOAD:=$(call AutoLoad,04,crc32c,1)
+endif
$(call AddDepends/crypto)
endef