ramips: dna_valokuitu-plus-ex400: clean-up image creation
authorMauri Sandberg <maukka@ext.kapsi.fi>
Mon, 28 Oct 2024 20:13:04 +0000 (22:13 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 24 Nov 2024 22:36:44 +0000 (23:36 +0100)
Code cleanup. Simplify and unify how kernel image is passed to
Build/dna-bootfs

Signed-off-by: Mauri Sandberg <maukka@ext.kapsi.fi>
Link: https://github.com/openwrt/openwrt/pull/16811
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ramips/image/mt7621.mk

index 1dc1219d241e465b162285642ae45a29e12fc629..eb7dacefefb7936df387308b490e637e828e7c46 100644 (file)
@@ -94,18 +94,9 @@ endef
 define Build/dna-bootfs
        mkdir -p $@.ubifs-dir/boot
 
-       # populate the boot fs with the dtb and with either initramfs kernel or
-       # the normal kernel
+       # populate the boot fs with the dtb and the kernel image
        $(CP) $(KDIR)/image-$(firstword $(DEVICE_DTS)).dtb $@.ubifs-dir/boot/dtb
-
-       $(if $(findstring with-initrd,$(word 1,$(1))),\
-               ( \
-                       $(CP) $@ $@.ubifs-dir/boot/uImage \
-               ) , \
-               ( \
-                       $(CP) $(IMAGE_KERNEL) $@.ubifs-dir/boot/uImage \
-               ) \
-       )
+       $(CP) $@ $@.ubifs-dir/boot/uImage
 
        # create ubifs
        $(STAGING_DIR_HOST)/bin/mkfs.ubifs ${MKUBIFS_OPTS} -r $@.ubifs-dir/ -o $@.new
@@ -1060,17 +1051,16 @@ define Device/dna_valokuitu-plus-ex400
   IMAGE_SIZE := 117m
   PAGESIZE := 2048
   MKUBIFS_OPTS := --min-io-size=$$(PAGESIZE) --leb-size=124KiB --max-leb-cnt=96 \
-                 --log-lebs=2 --space-fixup --squash-uids
+       --log-lebs=2 --space-fixup --squash-uids
   DEVICE_VENDOR := DNA
   DEVICE_MODEL := Valokuitu Plus EX400
   KERNEL := kernel-bin | lzma | uImage lzma
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
   IMAGES += factory.bin
   IMAGE/factory.bin := append-image-stage initramfs-kernel.bin | \
-                       dna-bootfs with-initrd | dna-header | \
-                       append-md5sum-ascii-salted
-  IMAGE/sysupgrade.bin := dna-bootfs | sysupgrade-tar kernel=$$$$@ | check-size | \
-                         append-metadata
+       dna-bootfs | dna-header | append-md5sum-ascii-salted
+  IMAGE/sysupgrade.bin := append-kernel | dna-bootfs | \
+       sysupgrade-tar kernel=$$$$@ | check-size | append-metadata
   DEVICE_IMG_NAME = $$(DEVICE_IMG_PREFIX)-$$(2)
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615-firmware kmod-usb3
 endef