compat-wireless: fix wl12xx driver
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 21 Sep 2010 20:26:31 +0000 (22:26 +0200)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 21 Sep 2010 22:20:19 +0000 (15:20 -0700)
This deactivate the wl1271_sdio driver, because it needs
wl12xx_platform_data.c directly compiled into the kernel.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
config.mk
scripts/admin-update.sh

index de5766f9aa44dbfa80380363f89a81e8d7033e42..19ea6b23576facc57526c1cb332284bbd5b0388e 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -485,7 +485,9 @@ ifdef CONFIG_CRC7
 CONFIG_WL1251_SDIO=m
 
 ifndef CONFIG_COMPAT_KERNEL_32
+ifdef CONFIG_WL12XX_PLATFORM_DATA
 CONFIG_WL1271_SDIO=m
+endif #CONFIG_WL12XX_PLATFORM_DATA
 endif #CONFIG_COMPAT_KERNEL_32
 
 endif #CONFIG_CRC7
index ac9470d1a8b595404ada27034da0882cc768c03c..91722f3bb6819d740b958a6a8f3df1f00485b37e 100755 (executable)
@@ -24,11 +24,12 @@ NET_BT_DIRS="bluetooth bluetooth/bnep bluetooth/cmtp bluetooth/rfcomm bluetooth/
 INCLUDE_LINUX="ieee80211.h nl80211.h"
 INCLUDE_LINUX="$INCLUDE_LINUX pci_ids.h eeprom_93cx6.h"
 INCLUDE_LINUX="$INCLUDE_LINUX ath9k_platform.h"
+INCLUDE_LINUX="$INCLUDE_LINUX wl12xx.h"
 
 # For rndis_wext
 INCLUDE_LINUX_USB="usbnet.h rndis_host.h"
 
-INCLUDE_LINUX_SPI="wl12xx.h libertas_spi.h"
+INCLUDE_LINUX_SPI="libertas_spi.h"
 
 # The good new yummy stuff
 INCLUDE_NET="cfg80211.h ieee80211_radiotap.h"