projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3e08b75
)
kernel: fix kmod-gre for Kernel >= 2.6.37 (#9009)
author
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 9 Mar 2011 21:57:03 +0000
(21:57 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 9 Mar 2011 21:57:03 +0000
(21:57 +0000)
SVN-Revision: 25985
package/kernel/modules/netsupport.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/netsupport.mk
b/package/kernel/modules/netsupport.mk
index 0988ba8235607f06fa5c99dfec82998fbbfe8dd3..29d5d151b534c146237af782c765ae84965b1bf1 100644
(file)
--- a/
package/kernel/modules/netsupport.mk
+++ b/
package/kernel/modules/netsupport.mk
@@
-370,8
+370,10
@@
$(eval $(call KernelPackage,ip6-tunnel))
define KernelPackage/gre
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=GRE support
- KCONFIG:=CONFIG_NET_IPGRE
- FILES=$(LINUX_DIR)/net/ipv4/ip_gre.ko
+ KCONFIG:=CONFIG_NET_IPGRE \
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
+ FILES=$(LINUX_DIR)/net/ipv4/ip_gre.ko \
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
endef
define KernelPackage/gre/description