ppp: clean up makefile
authorShiji Yang <yangshiji66@qq.com>
Sat, 5 Oct 2024 04:22:12 +0000 (12:22 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 12 Oct 2024 13:53:06 +0000 (15:53 +0200)
The latest ppp version seems to no longer require these ancient
build fixes.

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Link: https://github.com/openwrt/openwrt/pull/16605
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/network/services/ppp/Makefile

index 878c4fc481d2ae3b695f7a99f5e7dbbfa2d9a699..5f1ebd4e7d1bb7a792c690d7c21e9690f85b53c0 100644 (file)
@@ -184,37 +184,11 @@ This tool performs the same discovery process as pppoe, but does
 not initiate a session. Can be useful to debug pppoe.
 endef
 
-
-define Build/Configure
-$(call Build/Configure/Default,, \
-       UNAME_S="Linux" \
-       UNAME_R="$(LINUX_VERSION)" \
-       UNAME_M="$(ARCH)" \
-)
-       mkdir -p $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux
-       $(CP) \
-               $(LINUX_DIR)/include/linux/compiler.h \
-               $(LINUX_DIR)/include/$(LINUX_UAPI_DIR)linux/atm*.h \
-               $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
-
-       # Kernel 4.14.9+ only, ignore the exit status of cp in case the file
-       # doesn't exits
-       -$(CP) $(LINUX_DIR)/include/linux/compiler_types.h \
-               $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
-endef
-
-MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
-               STAGING_DIR="$(STAGING_DIR)"
-
 ifeq ($(BUILD_VARIANT),multilink)
   CONFIGURE_VARS += \
        enable_multilink=yes
 endif
 
-ifdef CONFIG_USE_MUSL
-  MAKE_FLAGS += USE_LIBUTIL=
-endif
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/pppd $(1)/usr/include/