projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
48a3a30
)
ar71xx: image: add mtdpartsize macro
author
Gabor Juhos
<juhosg@openwrt.org>
Sun, 22 Sep 2013 09:11:25 +0000
(09:11 +0000)
committer
Gabor Juhos
<juhosg@openwrt.org>
Sun, 22 Sep 2013 09:11:25 +0000
(09:11 +0000)
The new macro will be used to determine the firmware
partition size from an MTD layout.
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38117
target/linux/ar71xx/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/ar71xx/image/Makefile
b/target/linux/ar71xx/image/Makefile
index 60990b284d07f361796ec5b5110e319c99c8c09c..8ac70448d5b86b0a5d0b5780659a872015c3b496 100644
(file)
--- a/
target/linux/ar71xx/image/Makefile
+++ b/
target/linux/ar71xx/image/Makefile
@@
-31,6
+31,10
@@
define mkcmdline
$(if $(1),board=$(1) )$(if $(2),console=$(2)$(COMMA)$(3))
endef
+define mtdpartsize
+$(shell echo $$((`echo '$(2)' | sed -e 's/.*[:$(COMMA)]\([0-9]*\)k[@]*[0-9a-zx]*($(1)).*/\1/'` * 1024)))
+endef
+
SINGLE_PROFILES:=
define SingleProfile