kernel: add module for Emulex OneConnect 10Gbit
authorAlberto Bursi <alberto.bursi@outlook.it>
Sun, 15 Sep 2019 22:54:20 +0000 (00:54 +0200)
committerPetr Štetiar <ynezz@true.cz>
Sat, 21 Sep 2019 06:41:49 +0000 (08:41 +0200)
add module to support Emulex OneConnect
common in 10Gbit SFP+ cards by Dell/HP/IBM
supports OneConnect OCe10xxx OCe11xxx OCe14xxx,
LightPulse LPe12xxx

Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it>
(cherry picked from commit 827f47749b75dcc6b650297b9303c27127b15201)

package/kernel/linux/modules/netdevices.mk

index e77ddfd5f03dfaa656d973d5f879ca5b982cdbe2..6ea2f1df895527084d2db96954e0f6048aa34575 100644 (file)
@@ -991,3 +991,25 @@ define KernelPackage/bnx2/description
 endef
 
 $(eval $(call KernelPackage,bnx2))
+
+
+define KernelPackage/be2net
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Broadcom Emulex OneConnect 10Gbps NIC
+  DEPENDS:=@PCI_SUPPORT +kmod-hwmon-core
+  FILES:=$(LINUX_DIR)/drivers/net/ethernet/emulex/benet/be2net.ko
+  KCONFIG:= \
+       CONFIG_BE2NET \
+       CONFIG_BE2NET_BE2=y \
+       CONFIG_BE2NET_BE3=y \
+       CONFIG_BE2NET_LANCER=y \
+       CONFIG_BE2NET_SKYHAWK=y \
+       CONFIG_BE2NET_HWMON=y
+  AUTOLOAD:=$(call AutoProbe,be2net)
+endef
+
+define KernelPackage/be2net/description
+  Broadcom Emulex OneConnect 10Gbit SFP+ support, OneConnect OCe10xxx OCe11xxx OCe14xxx, LightPulse LPe12xxx
+endef
+
+$(eval $(call KernelPackage,be2net))