compat-drivers: refresh drm patches for next-20120925
authorLuis R. Rodriguez <mcgrof@do-not-panic.com>
Tue, 25 Sep 2012 20:38:38 +0000 (13:38 -0700)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Tue, 25 Sep 2012 20:38:38 +0000 (13:38 -0700)
Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
patches/drm/02-revert-vm_mmap.patch
patches/drm/04-revert-prime-support.patch
patches/drm/99-change-makefile.patch

index 09afc0045f9a2e98d8f998c80f143586a0196dac..9454223e1af5cb9786ded5bc4ede7309ba489c11 100644 (file)
@@ -36,7 +36,7 @@ These can't be backported as they rely on non-exported symbols.
                        /* Real error */
 --- a/drivers/gpu/drm/i810/i810_dma.c
 +++ b/drivers/gpu/drm/i810/i810_dma.c
-@@ -133,9 +133,17 @@ static int i810_map_buffer(struct drm_bu
+@@ -136,9 +136,17 @@ static int i810_map_buffer(struct drm_bu
        old_fops = file_priv->filp->f_op;
        file_priv->filp->f_op = &i810_buffer_fops;
        dev_priv->mmap_buffer = buf;
@@ -54,7 +54,7 @@ These can't be backported as they rely on non-exported symbols.
        dev_priv->mmap_buffer = NULL;
        file_priv->filp->f_op = old_fops;
        if (IS_ERR(buf_priv->virtual)) {
-@@ -156,9 +164,15 @@ static int i810_unmap_buffer(struct drm_
+@@ -159,9 +167,15 @@ static int i810_unmap_buffer(struct drm_
        if (buf_priv->currently_mapped != I810_BUF_MAPPED)
                return -EINVAL;
  
index b2eba6f75beccef2f5aa84c25a8750541bb8b515..256c81e9faee7c5f2494aaf5be3d51ee442ca40c 100644 (file)
@@ -41,8 +41,8 @@ not < 3.3.0.
                drm_prime_destroy_file_private(&file_priv->prime);
 +#endif
  
+       put_pid(file_priv->pid);
        kfree(file_priv);
 --- a/drivers/gpu/drm/drm_gem.c
 +++ b/drivers/gpu/drm/drm_gem.c
 @@ -35,7 +35,11 @@
@@ -289,7 +289,7 @@ not < 3.3.0.
  
 --- a/drivers/gpu/drm/i915/i915_drv.c
 +++ b/drivers/gpu/drm/i915/i915_drv.c
-@@ -956,7 +956,11 @@ static struct drm_driver driver = {
+@@ -955,7 +955,11 @@ static struct drm_driver driver = {
         */
        .driver_features =
            DRIVER_USE_AGP | DRIVER_REQUIRE_AGP | /* DRIVER_USE_MTRR |*/
@@ -301,7 +301,7 @@ not < 3.3.0.
        .load = i915_driver_load,
        .unload = i915_driver_unload,
        .open = i915_driver_open,
-@@ -979,10 +983,12 @@ static struct drm_driver driver = {
+@@ -978,10 +982,12 @@ static struct drm_driver driver = {
        .gem_free_object = i915_gem_free_object,
        .gem_vm_ops = &i915_gem_vm_ops,
  
@@ -326,7 +326,7 @@ not < 3.3.0.
  
  static void i915_gem_object_flush_gtt_write_domain(struct drm_i915_gem_object *obj);
  static void i915_gem_object_flush_cpu_write_domain(struct drm_i915_gem_object *obj);
-@@ -3700,8 +3702,10 @@ void i915_gem_free_object(struct drm_gem
+@@ -3701,8 +3703,10 @@ void i915_gem_free_object(struct drm_gem
  
        trace_i915_gem_object_destroy(obj);
  
index 08ed460f9d56219acfec46bf4f1fee48513b7c8b..70b8e15faa38e7d3b2a5565bafd711091ad8ba65 100644 (file)
@@ -2,7 +2,7 @@ Remove drivers that we do not want to build from gpu/drm/Makefile
 
 --- a/drivers/gpu/drm/Makefile
 +++ b/drivers/gpu/drm/Makefile
-@@ -28,21 +28,14 @@ CFLAGS_drm_trace_points.o := -I$(src)
+@@ -30,22 +30,15 @@ CFLAGS_drm_trace_points.o := -I$(src)
  obj-$(CONFIG_DRM)     += drm.o
  obj-$(CONFIG_DRM_USB)   += drm_usb.o
  obj-$(CONFIG_DRM_TTM) += ttm/
@@ -23,4 +23,5 @@ Remove drivers that we do not want to build from gpu/drm/Makefile
  obj-$(CONFIG_DRM_GMA500) += gma500/
 -obj-$(CONFIG_DRM_UDL) += udl/
  obj-$(CONFIG_DRM_AST) += ast/
+ obj-$(CONFIG_DRM_SHMOBILE) +=shmobile/
  obj-y                 += i2c/