projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5510149
)
package/kernel: update crypto.mk for kernel 2.6.36
author
Alexandros C. Couloumbis
<alex@ozo.com>
Mon, 6 Sep 2010 11:41:09 +0000
(11:41 +0000)
committer
Alexandros C. Couloumbis
<alex@ozo.com>
Mon, 6 Sep 2010 11:41:09 +0000
(11:41 +0000)
SVN-Revision: 22954
package/kernel/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/crypto.mk
b/package/kernel/modules/crypto.mk
index 421e37fa710ce3537e3ead51304fe6367bf2329a..9227deb80b9faa0e08bbf6d3786cff1edd146028 100644
(file)
--- a/
package/kernel/modules/crypto.mk
+++ b/
package/kernel/modules/crypto.mk
@@
-267,7
+267,8
@@
define KernelPackage/crypto-misc
$(LINUX_DIR)/crypto/sha256$(SHA256_SUFFIX).ko \
$(LINUX_DIR)/crypto/sha512$(SHA512_SUFFIX).ko \
$(LINUX_DIR)/crypto/tea.ko \
- $(LINUX_DIR)/crypto/twofish.ko \
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.35)),,$(LINUX_DIR)/crypto/twofish.ko) \
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),,$(LINUX_DIR)/crypto/twofish_generic.ko) \
$(LINUX_DIR)/crypto/wp512.ko
$(call AddDepends/crypto)
endef