net: hns3: Add HNS3 VF driver to kernel build framework
authorSalil Mehta <salil.mehta@huawei.com>
Thu, 14 Dec 2017 18:03:05 +0000 (18:03 +0000)
committerDavid S. Miller <davem@davemloft.net>
Fri, 15 Dec 2017 15:55:34 +0000 (10:55 -0500)
This patch introduces the new Makefiles and updates existing
Makefiles required to build the HNS3 Virtual Function driver.
This also updates the Kconfig for introduction of new menuconfig
entries related to VF driver.

Signed-off-by: Salil Mehta <salil.mehta@huawei.com>
Signed-off-by: lipeng <lipeng321@huawei.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
drivers/net/ethernet/hisilicon/Kconfig
drivers/net/ethernet/hisilicon/hns3/Makefile
drivers/net/ethernet/hisilicon/hns3/hns3vf/Makefile [new file with mode: 0644]

index 30000b6aa7b8fc1b93d73bd28229ea2737d20342..8bcf470ff5f38a4e62842a5f31d5c0b45141ab85 100644 (file)
@@ -94,15 +94,6 @@ config HNS3_HCLGE
          compatibility layer. The engine would be used in Hisilicon hip08 family of
          SoCs and further upcoming SoCs.
 
-config HNS3_ENET
-       tristate "Hisilicon HNS3 Ethernet Device Support"
-       depends on 64BIT && PCI
-       depends on HNS3 && HNS3_HCLGE
-       ---help---
-         This selects the Ethernet Driver for Hisilicon Network Subsystem 3 for hip08
-         family of SoCs. This module depends upon HNAE3 driver to access the HNAE3
-         devices and their associated operations.
-
 config HNS3_DCB
        bool "Hisilicon HNS3 Data Center Bridge Support"
        default n
@@ -112,4 +103,23 @@ config HNS3_DCB
 
          If unsure, say N.
 
+config HNS3_HCLGEVF
+    tristate "Hisilicon HNS3VF Acceleration Engine & Compatibility Layer Support"
+    depends on PCI_MSI
+    depends on HNS3
+       depends on HNS3_HCLGE
+    ---help---
+         This selects the HNS3 VF drivers network acceleration engine & its hardware
+         compatibility layer. The engine would be used in Hisilicon hip08 family of
+         SoCs and further upcoming SoCs.
+
+config HNS3_ENET
+       tristate "Hisilicon HNS3 Ethernet Device Support"
+       depends on 64BIT && PCI
+       depends on HNS3
+       ---help---
+         This selects the Ethernet Driver for Hisilicon Network Subsystem 3 for hip08
+         family of SoCs. This module depends upon HNAE3 driver to access the HNAE3
+         devices and their associated operations.
+
 endif # NET_VENDOR_HISILICON
index a9349e1f3e519cb73e7631459a9d4a7e94bc0c38..c45094513c871f4409bc187af72ddf4c245ed426 100644 (file)
@@ -1,7 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0+
 #
 # Makefile for the HISILICON network device drivers.
 #
 
 obj-$(CONFIG_HNS3) += hns3pf/
+obj-$(CONFIG_HNS3) += hns3vf/
 
 obj-$(CONFIG_HNS3) += hnae3.o
diff --git a/drivers/net/ethernet/hisilicon/hns3/hns3vf/Makefile b/drivers/net/ethernet/hisilicon/hns3/hns3vf/Makefile
new file mode 100644 (file)
index 0000000..fb93bbd
--- /dev/null
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0+
+#
+# Makefile for the HISILICON network device drivers.
+#
+
+ccflags-y := -Idrivers/net/ethernet/hisilicon/hns3
+
+obj-$(CONFIG_HNS3_HCLGEVF) += hclgevf.o
+hclgevf-objs = hclgevf_main.o hclgevf_cmd.o hclgevf_mbx.o
\ No newline at end of file