set Attitude Adjustment specifc names and urls
authorJohn Crispin <john@openwrt.org>
Fri, 5 Oct 2012 10:44:43 +0000 (10:44 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 5 Oct 2012 10:44:43 +0000 (10:44 +0000)
SVN-Revision: 33627

feeds.conf.default
include/version.mk
package/base-files/image-config.in

index 518bf68ad032dc7de1662c1872328492f02c3f2a..9dd1414236822d45dbc292d42b421e6da4f413a7 100644 (file)
@@ -1,6 +1,6 @@
-src-svn packages svn://svn.openwrt.org/openwrt/packages
+src-svn packages svn://svn.openwrt.org/openwrt/branches/packages_12.09
 src-svn xwrt http://x-wrt.googlecode.com/svn/trunk/package
-src-svn luci http://svn.luci.subsignal.org/luci/trunk/contrib/package
+src-svn luci http://svn.luci.subsignal.org/luci/branches/luci-0.11/contrib/package
 #src-svn phone svn://svn.openwrt.org/openwrt/feeds/phone
 #src-svn efl svn://svn.openwrt.org/openwrt/feeds/efl
 #src-svn xorg svn://svn.openwrt.org/openwrt/feeds/xorg
index 2bf709e56e69fc663af24ed5e939ca8611fe525c..7aa50186cdeca190905c48ea3596f960c441daf9 100644 (file)
@@ -15,16 +15,16 @@ PKG_CONFIG_DEPENDS += \
        CONFIG_VERSION_DIST
 
 VERSION_NUMBER:=$(call qstrip,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),$(REVISION))
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),12.09-beta2)
 
 VERSION_CODE:=$(call qstrip,$(CONFIG_VERSION_NUMBER))
-VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),Bleeding Edge)
+VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),Attitude Adjustment)
 
 VERSION_NICK:=$(call qstrip,$(CONFIG_VERSION_NICK))
 VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
 
 VERSION_REPO:=$(call qstrip,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%T/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/attitude_adjustment/12.09-beta2/%S/packages)
 
 VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
index ac08c8da7ce26dda283666d1b0a3e38aecccb043..2e15d160848697362455e757b6110e4b7975f355 100644 (file)
@@ -153,6 +153,7 @@ menuconfig VERSIONOPT
        config VERSION_NICK
                string
                prompt "Release version nickname" if VERSIONOPT
+               default "Attitude Adjustment" if VERSIONOPT
                help
                        This is the release codename embedded in the image.
                        If unspecified, it defaults to the name of source branch.
@@ -168,7 +169,7 @@ menuconfig VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository" if VERSIONOPT
-               default "http://downloads.openwrt.org/snapshots/trunk/%T/packages" if VERSIONOPT
+               default "http://downloads.openwrt.org/attitude_adjustment/12.09-beta2/%S/packages" if VERSIONOPT
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders: