projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
23fc737
)
download.mk: refuse to download mirror tarballs from packages using version control...
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 6 Jun 2012 13:45:53 +0000
(13:45 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 6 Jun 2012 13:45:53 +0000
(13:45 +0000)
SVN-Revision: 32079
include/download.mk
patch
|
blob
|
history
diff --git
a/include/download.mk
b/include/download.mk
index 6cc10d95c3057e49fe17454f0873cbc67608b17d..823ddf93f882c426cc9b9a36b3fe02be82f49a84 100644
(file)
--- a/
include/download.mk
+++ b/
include/download.mk
@@
-45,7
+45,7
@@
define DownloadMethod/default
endef
define wrap_mirror
- $(if $(
MIRROR
),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" || ( $(1) ),$(1))
+ $(if $(
if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))
),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" || ( $(1) ),$(1))
endef
define DownloadMethod/cvs