projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
539b02f
)
[backfire] backport r22517
author
Andy Boyett
<agb@openwrt.org>
Sun, 12 Dec 2010 21:41:04 +0000
(21:41 +0000)
committer
Andy Boyett
<agb@openwrt.org>
Sun, 12 Dec 2010 21:41:04 +0000
(21:41 +0000)
[include] support unpacking of .tar.xz archives, no prereq on xzcat for now
SVN-Revision: 24524
include/unpack.mk
patch
|
blob
|
history
diff --git
a/include/unpack.mk
b/include/unpack.mk
index 2cd17817e6929d216cf31acb1c8514848eb4ecfd..01516757771a17f40692e424b14f860781676406 100644
(file)
--- a/
include/unpack.mk
+++ b/
include/unpack.mk
@@
-32,7
+32,11
@@
ifeq ($(strip $(UNPACK_CMD)),)
EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
DECOMPRESS_CMD:=bzcat $(DL_DIR)/$(PKG_SOURCE) |
endif
- ifeq ($(filter tgz tbz tbz2,$(EXT1)),$(EXT1))
+ ifeq ($(filter xz txz,$(EXT)),$(EXT))
+ EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
+ DECOMPRESS_CMD:=xzcat $(DL_DIR)/$(PKG_SOURCE) |
+ endif
+ ifeq ($(filter tgz tbz tbz2 txz,$(EXT1)),$(EXT1))
EXT:=tar
endif
DECOMPRESS_CMD ?= cat $(DL_DIR)/$(PKG_SOURCE) |