uboot-mvebu: update to version 2024.10
authorStefan Kalscheuer <stefan@stklcode.de>
Sat, 12 Oct 2024 09:08:50 +0000 (11:08 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 19 Oct 2024 20:54:12 +0000 (22:54 +0200)
Update package to the latest stable version and drop upstreamed patches:
  0001-arm-mvebu-turris_omnia-Enable-LTO-by-default-on-Turr.patch
  100-mvebu-armada-8k-respect-CONFIG_DISTRO_DEFAULTS.patch

Other patches automatically refreshed (line numbers only)

Add custom config flags to disable building efimkcapsule by default.
This introduces a dependency to GnuTLS which is not present and we do
not need it here.

Signed-off-by: Stefan Kalscheuer <stefan@stklcode.de>
Link: https://github.com/openwrt/openwrt/pull/16676
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/uboot-mvebu/Makefile
package/boot/uboot-mvebu/patches/0001-arm-mvebu-turris_omnia-Enable-LTO-by-default-on-Turr.patch [deleted file]
package/boot/uboot-mvebu/patches/100-mvebu-armada-8k-respect-CONFIG_DISTRO_DEFAULTS.patch [deleted file]
package/boot/uboot-mvebu/patches/101-net-mvpp2-fix-10GBase-R-support.patch
package/boot/uboot-mvebu/patches/102-arm-mvebu-add-support-for-MikroTik-RB5009UG-S-IN.patch

index 535180f4c8e1776e9b2b69fc457e0041b5516681..d4c86aca29305b988439619c65b62519830aa333 100644 (file)
@@ -8,10 +8,10 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_VERSION:=2024.04
+PKG_VERSION:=2024.10
 PKG_RELEASE:=1
 
-PKG_HASH:=18a853fe39fad7ad03a90cc2d4275aeaed6da69735defac3492b80508843dd4a
+PKG_HASH:=b28daf4ac17e43156363078bf510297584137f6df50fced9b12df34f61a92fb0
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
@@ -77,6 +77,9 @@ UBOOT_TARGETS:= \
        eDPU \
        rb5009
 
+UBOOT_CUSTOMIZE_CONFIG := \
+       --disable TOOLS_MKEFICAPSULE
+
 define Package/u-boot/install
        $(if $(findstring cortexa53,$(BUILD_SUBTARGET)),,$(Package/u-boot/install/default))
 endef
diff --git a/package/boot/uboot-mvebu/patches/0001-arm-mvebu-turris_omnia-Enable-LTO-by-default-on-Turr.patch b/package/boot/uboot-mvebu/patches/0001-arm-mvebu-turris_omnia-Enable-LTO-by-default-on-Turr.patch
deleted file mode 100644 (file)
index 3381e05..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From ca4ecdce4cdcfab7df101b5df6ddad43d2f549e1 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Marek=20Beh=C3=BAn?= <kabel@kernel.org>
-Date: Thu, 4 Apr 2024 09:50:50 +0200
-Subject: [PATCH] arm: mvebu: turris_omnia: Enable LTO by default on Turris
- Omnia
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-U-Boot builds for Turris Omnia are approaching the limit of 0xf0000
-bytes, which is the size of the U-Boot partition on Omnia.
-
-Enable LTO to get more size optimized binaries.
-
-Signed-off-by: Marek BehĂșn <kabel@kernel.org>
-Reviewed-by: Stefan Roese <sr@denx.de>
----
- configs/turris_omnia_defconfig | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/configs/turris_omnia_defconfig
-+++ b/configs/turris_omnia_defconfig
-@@ -31,6 +31,7 @@ CONFIG_AHCI=y
- CONFIG_OF_BOARD_FIXUP=y
- CONFIG_SYS_MEMTEST_START=0x00800000
- CONFIG_SYS_MEMTEST_END=0x00ffffff
-+CONFIG_LTO=y
- CONFIG_HAS_BOARD_SIZE_LIMIT=y
- CONFIG_BOARD_SIZE_LIMIT=983040
- CONFIG_FIT=y
diff --git a/package/boot/uboot-mvebu/patches/100-mvebu-armada-8k-respect-CONFIG_DISTRO_DEFAULTS.patch b/package/boot/uboot-mvebu/patches/100-mvebu-armada-8k-respect-CONFIG_DISTRO_DEFAULTS.patch
deleted file mode 100644 (file)
index f32f246..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From a322b1cbb3f3e606d33a11fd18df20811e5c16f2 Mon Sep 17 00:00:00 2001
-From: Robert Marko <robimarko@gmail.com>
-Date: Fri, 21 Jun 2024 11:41:30 +0200
-Subject: [PATCH 1/3] mvebu: armada-8k: respect CONFIG_DISTRO_DEFAULTS
-
-Currently, Armada 8k config header is setting boot devices and including
-<config_distro_bootcmd.h> regardless of the CONFIG_DISTRO_DEFAULTS being
-enabled or not, thus populating the environment for distro boot even on
-devices that have no need for it.
-
-So, lets simply respect the value of CONFIG_DISTRO_DEFAULTS.
-
-Signed-off-by: Robert Marko <robimarko@gmail.com>
----
- include/configs/mvebu_armada-8k.h | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
---- a/include/configs/mvebu_armada-8k.h
-+++ b/include/configs/mvebu_armada-8k.h
-@@ -30,7 +30,7 @@
- /*
-  * PCI configuration
-  */
--
-+#ifdef CONFIG_DISTRO_DEFAULTS
- #define BOOT_TARGET_DEVICES(func) \
-       func(MMC, mmc, 1) \
-       func(MMC, mmc, 0) \
-@@ -40,6 +40,9 @@
-       func(DHCP, dhcp, na)
- #include <config_distro_bootcmd.h>
-+#else
-+#define BOOTENV
-+#endif
- #define CFG_EXTRA_ENV_SETTINGS        \
-       "scriptaddr=0x6d00000\0"        \
index eb7bbdbf484497720917079cfd9e15d64952f766..0fe3a4cbb6bdc93c8fc959d701a084376155ffa0 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
 
 --- a/drivers/net/mvpp2.c
 +++ b/drivers/net/mvpp2.c
-@@ -3255,6 +3255,76 @@ static int gop_gpcs_reset(struct mvpp2_p
+@@ -3254,6 +3254,76 @@ static int gop_gpcs_reset(struct mvpp2_p
        return 0;
  }
  
@@ -95,7 +95,7 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
  static int gop_mpcs_mode(struct mvpp2_port *port)
  {
        u32 val;
-@@ -3397,7 +3467,10 @@ static int gop_port_init(struct mvpp2_po
+@@ -3396,7 +3466,10 @@ static int gop_port_init(struct mvpp2_po
                num_of_act_lanes = 2;
                mac_num = 0;
                /* configure PCS */
index b1b94cc566a3c27327884491879270ab37caee38..473053210016bd80e3419c600afbd42799d4865d 100644 (file)
@@ -31,7 +31,7 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
 
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -333,6 +333,7 @@ dtb-$(CONFIG_ARCH_MVEBU) +=                        \
+@@ -177,6 +177,7 @@ dtb-$(CONFIG_ARCH_MVEBU) +=                        \
        armada-3720-uDPU.dtb                    \
        armada-7040-db-nand.dtb                 \
        armada-7040-db.dtb                      \