projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5dd7455
)
kernel: add missing dependency to regmap to kmod-gpio-mcp23s08
author
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 25 Aug 2018 16:11:03 +0000
(18:11 +0200)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 25 Aug 2018 16:18:35 +0000
(18:18 +0200)
This fixes a build problem recently introduced.
Fixes: a904003b9b5f ("kernel: fix kmod-gpio-mcp23s08 for linux 4.14")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/other.mk
b/package/kernel/linux/modules/other.mk
index 279c1598787f531ba8df62ea032c2415fd227246..7df93d3a01157837aa58def58d208c79842c623c 100644
(file)
--- a/
package/kernel/linux/modules/other.mk
+++ b/
package/kernel/linux/modules/other.mk
@@
-227,7
+227,7
@@
$(eval $(call KernelPackage,gpio-dev))
define KernelPackage/gpio-mcp23s08
SUBMENU:=$(OTHER_MENU)
TITLE:=Microchip MCP23xxx I/O expander
- DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
+ DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
+LINUX_4_14:kmod-regmap
KCONFIG:= \
CONFIG_GPIO_MCP23S08 \
CONFIG_PINCTRL_MCP23S08