Add missing CONFIG_COMPAT tags to make wireless start building again
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Fri, 11 Dec 2009 06:24:17 +0000 (22:24 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Fri, 11 Dec 2009 06:24:17 +0000 (22:24 -0800)
Also renames compat.h to compat-2.6.h to match compat.git

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
Makefile
config.mk
patches/03-rfkill.patch
patches/98-add-compat-wireless.patch
scripts/admin-update.sh

index 8f12d8a04e55e84fb3bf4c1948118058487419b8..afeef851ee926488026598dfa1cc5ad99c20cddf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -17,23 +17,25 @@ ifneq ($(KERNELRELEASE),)
 
 include $(M)/$(COMPAT_CONFIG)
 
-NOSTDINC_FLAGS := -I$(M)/include/ -include $(M)/include/linux/compat.h $(CFLAGS)
+NOSTDINC_FLAGS := -I$(M)/include/ -include $(M)/include/linux/compat-2.6.h $(CFLAGS)
 
 obj-y := compat/
 
 obj-$(COMPAT_RFKILL) += net/rfkill/
-obj-$(CONFIG_COMPAT_BT) += net/bluetooth/
+
 obj-$(CONFIG_COMPAT_WIRELESS) += net/wireless/ net/mac80211/
+obj-$(CONFIG_COMPAT_WIRELESS_MODULES) += drivers/net/wireless/
+
+obj-$(CONFIG_COMPAT_NET_USB_MODULES) += drivers/net/usb/
+
+obj-$(CONFIG_COMPAT_BT) += net/bluetooth/
+obj-$(CONFIG_COMPAT_BLUETOOTH_MODULES) += drivers/bluetooth/
 
 obj-$(CONFIG_COMPAT_NETWORK_MODULES) += drivers/net/
 obj-$(CONFIG_COMPAT_VAR_MODULES) +=  drivers/misc/eeprom/
 # Sorry ssb requires pcmica backport for 2.6.33 which is not done yet
 #                                      drivers/ssb/
 
-obj-$(CONFIG_COMPAT_NET_USB_MODULES) += drivers/net/usb/
-obj-$(CONFIG_COMPAT_WIRELESS_MODULES) += drivers/net/wireless/
-obj-$(CONFIG_COMPAT_BLUETOOTH_MODULES) += drivers/bluetooth/
-
 else
 
 export PWD :=  $(shell pwd)
index 3f70defab3cd9f7fd05e51d77b835c063cd3c552..874c27e13565e7f5a20553bd76ed61f41db47178 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -21,8 +21,8 @@ endif
 ifeq ($(CONFIG_MAC80211),y)
 $(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
 else
- CONFIG_COMPAT_KERNEL=y
- CONFIG_COMPAT_KERNEL_MODULES=m
+ CONFIG_COMPAT_WIRELESS=y
+ CONFIG_COMPAT_WIRELESS_MODULES=m
  CONFIG_COMPAT_VAR_MODULES=m
 # We could technically separate these but not yet, we only have b44
 # Note that we don't intend on backporting network drivers that
@@ -35,7 +35,7 @@ endif
 ifeq ($(CONFIG_BT),y)
 # we'll ignore compiling bluetooth
 else
-CONFIG_COMPAT_BT=y
+CONFIG_COMPAT_BLUETOOTH=y
 CONFIG_COMPAT_BLUETOOTH_MODULES=m
 endif
 
index 02cdbe2abd37ac87cb2dae2fb7258fd49160c0f5..8da7489401d856b2d4d64deb5665b54b4bff8a4a 100644 (file)
@@ -170,7 +170,7 @@ This would do the policing from within mac80211.
   */
  
  #include <linux/types.h>
-+#include <linux/compat.h>
++#include <linux/compat-2.6.h>
  
  /* define userspace visible states */
  #define RFKILL_STATE_SOFT_BLOCKED     0
index 05a45cedfa02e76881cf828f866ad6cb1d1fb428..5e637ad43237504b02b0a39a02b9ed7a73e8abf9 100644 (file)
@@ -24,7 +24,7 @@ added compat.h also for ssb, I forget.
  /* remove once we remove the wext stuff */
  #include <net/iw_handler.h>
  #include <linux/wireless.h>
-+#include <linux/compat.h>
++#include <linux/compat-2.6.h>
  
  
  /*
index ec5bd1cc0943526b7869da2fa0ec983e83e71648..f8bf87a3a6a7e5144f10719343f6a60d7322865a 100755 (executable)
@@ -196,7 +196,8 @@ done
 # b44 is dependent on ssb, so its has to be rebuilt as well.
 DIR="drivers/net"
 cp $GIT_TREE/$DIR/b44.[ch] $DIR
-echo "obj-\$(CONFIG_B44) += b44.o" > $DIR/Makefile
+# Not yet
+#echo "obj-\$(CONFIG_B44) += b44.o" > $DIR/Makefile
 
 # Misc
 mkdir -p drivers/misc/eeprom/