projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f1194ac
)
create package directory if it doesn't exist while building base-files
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 20 Mar 2006 02:21:49 +0000
(
02:21
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 20 Mar 2006 02:21:49 +0000
(
02:21
+0000)
SVN-Revision: 3417
openwrt/package/base-files/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/package/base-files/Makefile
b/openwrt/package/base-files/Makefile
index dcd6aa0d546e614e943776584ff0288fd66586ec..a70fbcf134bbf3a248685d90c42cc6e4e1184012 100644
(file)
--- a/
openwrt/package/base-files/Makefile
+++ b/
openwrt/package/base-files/Makefile
@@
-75,10
+75,15
@@
$(IPKG_GCC):
-$(STRIP) $(IDIR_GCC)/lib/*
$(IPKG_BUILD) $(IDIR_GCC) $(PACKAGE_DIR)
+$(PACKAGE_DIR):
+ mkdir -p $@
+
+$(PACKAGES): $(PACKAGE_DIR)
+
package-clean:
rm -f $(PACKAGES)
clean: package-clean
-prepare:
+prepare:
compile: $(PACKAGES)
install: compile
mkdir -p $(TARGET_DIR)