projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
96414cb
)
iptables: fix wrong depends for nftables support (FS#707)
author
Ansuel Smith
<ansuelsmth@gmail.com>
Sat, 22 Apr 2017 17:57:09 +0000
(19:57 +0200)
committer
Felix Fietkau
<nbd@nbd.name>
Sat, 22 Apr 2017 19:33:46 +0000
(21:33 +0200)
The dep for the nftables support was wrong, if someone actually enable
that option gain a compilation error. This fix this problem.
Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
package/network/utils/iptables/Makefile
patch
|
blob
|
history
diff --git
a/package/network/utils/iptables/Makefile
b/package/network/utils/iptables/Makefile
index ae2377e578265558606358217a9cdea02cc3fd8d..ca8b1976aa194368491d0e2d015d4467dfd2dd9e 100644
(file)
--- a/
package/network/utils/iptables/Makefile
+++ b/
package/network/utils/iptables/Makefile
@@
-432,7
+432,7
@@
define Package/libxtables
ABI_VERSION:=$(PKG_VERSION)
DEPENDS:= \
+IPTABLES_CONNLABEL:libnetfilter-conntrack \
- +IPTABLES_NFTABLES:libnf
netlink
+ +IPTABLES_NFTABLES:libnf
tnl
endef
TARGET_CPPFLAGS := \