add avrdude
authorNicolas Thill <nico@openwrt.org>
Fri, 16 May 2008 03:31:21 +0000 (03:31 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 May 2008 03:31:21 +0000 (03:31 +0000)
SVN-Revision: 11146

utils/avrdude/Makefile [new file with mode: 0644]

diff --git a/utils/avrdude/Makefile b/utils/avrdude/Makefile
new file mode 100644 (file)
index 0000000..8ba1608
--- /dev/null
@@ -0,0 +1,53 @@
+# 
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=avrdude
+PKG_VERSION:=5.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:= http://download.savannah.gnu.org/releases/avrdude/
+PKG_MD5SUM:=60180d3f5f467987bfd7bc4505796fae
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/avrdude
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=AVR Downloader/UploaDEr
+  URL:=http://www.bsdhome.com/avrdude/
+  DEPENDS:=+libncurses
+endef
+
+define Package/avrdude/description
+ AVRDUDE is a full featured program for programming Atmel's AVR CPU's.
+endef
+
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --disable-static \
+       --disable-parport \
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+endef
+
+define Package/avrdude/conffiles
+/etc/avrdude.conf
+endef
+
+define Package/avrdude/install
+       $(INSTALL_DIR) $(1)/etc
+       $(CP) $(PKG_INSTALL_DIR)/etc/avrdude.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/avrdude $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,avrdude))