ixp4xx: Add back support for D-Link DSM G600 A
authorLinus Walleij <linus.walleij@linaro.org>
Tue, 21 May 2024 07:30:28 +0000 (09:30 +0200)
committerLinus Walleij <linus.walleij@linaro.org>
Sat, 25 May 2024 07:17:19 +0000 (09:17 +0200)
OpenWrt supported the D-Link DSM G600 A in the past. It has
64 MB of RAM and 16 MB of flash so it will run just fine,
and should be quite usable with a rootfs on an external
harddrive.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
target/linux/ixp4xx/base-files/etc/board.d/02_network
target/linux/ixp4xx/image/Makefile

index 7f75a2e20d335f7db009e747c06b26cd55ecb827..6a361d4f533e6a9cf13f6e250605a04e6829dfbe 100644 (file)
@@ -9,6 +9,7 @@ gateworks,gw2348|\
 gateworks,gw2358)
        ucidef_set_interfaces_lan_wan "eth0" "eth1"
        ;;
+dlink,dsm-g600-a|\
 iom,nas-100d|\
 linksys,nslu2)
        ucidef_set_interface_lan "eth0" "dhcp"
index 15f40821eb21bc40e23a4b9860ab7e5a80c0d11f..ace533e50f0605ab7a7b3c1a3b28d749686c1ec2 100644 (file)
@@ -46,6 +46,18 @@ define Device/Default
        BLOCKSIZE := 128k
 endef
 
+define Device/dlink_dsm_g600_a
+       DEVICE_VENDOR := D-Link
+       DEVICE_MODEL := DSM G600 A
+       DEVICE_PACKAGES := ixp4xx-microcode-ethernet kmod-rtc-pcf8563 kmod-via-velocity kmod-ata-artop kmod-ath5k wpad-basic-mbedtls
+       DEVICE_DTS := intel-ixp42x-dlink-dsm-g600
+       KERNEL := kernel-bin | append-dtb
+       IMAGES := kernel.bin rootfs.bin
+       IMAGE/kernel.bin := append-kernel
+       IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to 128k
+endef
+TARGET_DEVICES += dlink_dsm_g600_a
+
 define Device/freecom_fsg_3
        DEVICE_VENDOR := Freecom
        DEVICE_MODEL := FSG-3