projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c584683
)
kernel: add kmod-media-controller dependency for kmod-usb-audio
author
Thomas Richard
<thomas.richard@bootlin.com>
Tue, 5 Nov 2024 10:23:36 +0000
(11:23 +0100)
committer
Petr Štetiar
<ynezz@true.cz>
Thu, 28 Nov 2024 18:48:48 +0000
(18:48 +0000)
The snd-usb-audio drivers uses media controller if media controller is set.
So add kmod-media-controller as dependency.
Signed-off-by: Thomas Richard <thomas.richard@bootlin.com>
Link:
https://github.com/openwrt/openwrt/pull/16716
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit
109592524663ae8bbda47e4ad51a124153a1c903
)
Link:
https://github.com/openwrt/openwrt/pull/17097
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/kernel/linux/modules/usb.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/usb.mk
b/package/kernel/linux/modules/usb.mk
index 458c8c4ba68f8626f0a4bcc62a8b5d0d8b03aceb..466c547e8ab2dd75130fba21201fd85fe9861fc4 100644
(file)
--- a/
package/kernel/linux/modules/usb.mk
+++ b/
package/kernel/linux/modules/usb.mk
@@
-576,6
+576,7
@@
define KernelPackage/usb-audio
CONFIG_SND_USB_AUDIO
$(call AddDepends/usb)
$(call AddDepends/sound)
+ DEPENDS+=kmod-media-controller
FILES:= \
$(LINUX_DIR)/sound/usb/snd-usbmidi-lib.ko \
$(LINUX_DIR)/sound/usb/snd-usb-audio.ko