projects
/
openwrt
/
staging
/
noltari.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5bac623
)
toolchain: Include hardening.mk for toolchain build
author
Hauke Mehrtens
<hauke@hauke-m.de>
Tue, 1 Jan 2019 23:34:18 +0000
(
00:34
+0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Thu, 24 Jan 2019 20:52:39 +0000
(21:52 +0100)
This adds the hardening options also to the toolchain build.
With this change the /usr/lib/libstdc++.so.6.0.24 library will have
stack canaries and the /lib/libgcc_s.so.1 library will have Full RELRO.
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/toolchain-build.mk
patch
|
blob
|
history
diff --git
a/include/toolchain-build.mk
b/include/toolchain-build.mk
index 883d74d25c8285b1693ef2047d953f7b5f413e6e..35d8c9380ec190e45b48319b9fe75d15ca8c33f7 100644
(file)
--- a/
include/toolchain-build.mk
+++ b/
include/toolchain-build.mk
@@
-12,6
+12,7
@@
HOST_BUILD_PREFIX:=$(TOOLCHAIN_DIR)
BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/hardening.mk
HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared