projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ff96bd8
)
kernel: package snd-soc-dmic driver
author
Thomas Richard
<thomas.richard@bootlin.com>
Fri, 25 Oct 2024 13:21:57 +0000
(15:21 +0200)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 23 Nov 2024 14:53:21 +0000
(15:53 +0100)
It is needed for the stm32/stm32mp1 subtarget.
Signed-off-by: Thomas Richard <thomas.richard@bootlin.com>
Link:
https://github.com/openwrt/openwrt/pull/16716
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/sound.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/sound.mk
b/package/kernel/linux/modules/sound.mk
index 623f65ac59add12a5a0b9c4a0c45d511617a510e..f3e44e01eee82d1d0f99ec59f4d0ef52568cebb8 100644
(file)
--- a/
package/kernel/linux/modules/sound.mk
+++ b/
package/kernel/linux/modules/sound.mk
@@
-314,6
+314,17
@@
endef
$(eval $(call KernelPackage,sound-soc-spdif))
+define KernelPackage/sound-soc-dmic
+ TITLE:=Generic Digital Microphone CODEC
+ KCONFIG:=CONFIG_SND_SOC_DMIC
+ FILES:=$(LINUX_DIR)/sound/soc/codecs/snd-soc-dmic.ko
+ AUTOLOAD:=$(call AutoProbe,snd-soc-dmic)
+ $(call AddDepends/sound,+kmod-sound-soc-core)
+endef
+
+$(eval $(call KernelPackage,sound-soc-dmic))
+
+
define KernelPackage/pcspkr
DEPENDS:=@TARGET_x86 +kmod-input-core
TITLE:=PC speaker support