mediatek: fix OpenWrt One ubinized image in IB
authorDaniel Golle <daniel@makrotopia.org>
Sat, 19 Oct 2024 23:48:57 +0000 (00:48 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 20 Oct 2024 23:49:22 +0000 (00:49 +0100)
The ImageBuilder when using the profile for the OpenWrt One has been
failing because the initramfs image included in the ubinized image could
not be found.

Fix that by using the staged initramfs instead when using the
ImageBuilder.

Fixes: 797904b3cb ("mediatek/filogic: add OpenWrt One support")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/image/filogic.mk

index 83f1336444d8c6288f7c084c3e87d38c6e6e697a..ac535aeaa0f8d12e325405fa14b68546f4b2f387 100644 (file)
@@ -1090,7 +1090,9 @@ define Device/openwrt_one
   UBINIZE_OPTS := -E 5
   BLOCKSIZE := 128k
   PAGESIZE := 2048
-  UBINIZE_PARTS := fip=:$(STAGING_DIR_IMAGE)/mt7981_openwrt_one-snand-u-boot.fip recovery=:$(KDIR)/tmp/openwrt-mediatek-filogic-openwrt_one-initramfs.itb \
+  UBINIZE_PARTS := fip=:$(STAGING_DIR_IMAGE)/mt7981_openwrt_one-snand-u-boot.fip \
+                  $(if $(IB),recovery=:$(STAGING_DIR_IMAGE)/mediatek-filogic-openwrt_one-initramfs.itb,\
+                             recovery=:$(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE)) \
                   $(if $(wildcard $(TOPDIR)/openwrt-mediatek-filogic-openwrt_one-calibration.itb), calibration=:$(TOPDIR)/openwrt-mediatek-filogic-openwrt_one-calibration.itb)
 endef
 TARGET_DEVICES += openwrt_one