nfs-server: add support for building with external librpc
authorFelix Fietkau <nbd@openwrt.org>
Sun, 13 Feb 2011 01:45:26 +0000 (01:45 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 13 Feb 2011 01:45:26 +0000 (01:45 +0000)
SVN-Revision: 25500

net/nfs-server/Makefile

index bc168a0560c08b6098ca9f29f2be6430fd2ac954..eb8948f6568bbfef918730c22bc08c88a1da5e3f 100644 (file)
@@ -34,6 +34,9 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)
 endef
 
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+TARGET_LDFLAGS += $(LIBRPC)
+
 define Package/nfs-server/install      
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/nfsd.exports $(1)/etc/exports