projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1827b31
)
kernel: other: limit serial-8250-exar to devices with PCI support
author
Aleksander Jan Bajkowski
<olek2@wp.pl>
Fri, 2 Dec 2022 22:48:02 +0000
(23:48 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Tue, 9 May 2023 09:40:59 +0000
(11:40 +0200)
Kmod-serial-8250-exar supports Serial cards connected via PCIe bus. On targets
without PCI support, this package is empty.
Signed-off-by: Aleksander Jan Bajkowski <olek2@wp.pl>
package/kernel/linux/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/other.mk
b/package/kernel/linux/modules/other.mk
index 262aca43242bf8a2f8da32420ca8eaa59faeafc8..75e978085b4b77d031f9d2eb8e81f7fc2a99e4e6 100644
(file)
--- a/
package/kernel/linux/modules/other.mk
+++ b/
package/kernel/linux/modules/other.mk
@@
-901,7
+901,7
@@
define KernelPackage/serial-8250-exar
KCONFIG:= CONFIG_SERIAL_8250_EXAR
FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250_exar.ko
AUTOLOAD:=$(call AutoProbe,8250 8250_base 8250_exar)
- DEPENDS:=+kmod-serial-8250
+ DEPENDS:=
@PCI_SUPPORT
+kmod-serial-8250
endef
define KernelPackage/serial-8250-exar/description