projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cb2a848
)
build: move the CCACHE_DIR to the build targets so that it doesn't interfere with...
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 15 Mar 2011 19:59:58 +0000
(19:59 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 15 Mar 2011 19:59:58 +0000
(19:59 +0000)
SVN-Revision: 26182
include/package.mk
patch
|
blob
|
history
rules.mk
patch
|
blob
|
history
diff --git
a/include/package.mk
b/include/package.mk
index 21b3bff337c3c42b67d9f45d64fbf65eeda6378b..4c1d13864cd575fa9e89b3d494075d2c025825e7 100644
(file)
--- a/
include/package.mk
+++ b/
include/package.mk
@@
-84,6
+84,7
@@
define Build/Exports/Default
$(1) : export CONFIG_SITE:=$$(CONFIG_SITE)
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR)/usr/lib/pkgconfig
$(1) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR)/usr/lib/pkgconfig
+ $(1) : export CCACHE_DIR:=$(STAGING_DIR)/ccache
endef
Build/Exports=$(Build/Exports/Default)
diff --git
a/rules.mk
b/rules.mk
index 1a58c6ae57b47e62132e20f55f602fcfdcb5fc4d..0068350ed2ed22624996117e2ae5d6527e7fca11 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-174,8
+174,6
@@
INSTALL_DATA:=install -m0644
INSTALL_CONF:=install -m0600
ifneq ($(CONFIG_CCACHE),)
- # FIXME: move this variable to a better location
- export CCACHE_DIR=$(STAGING_DIR)/ccache
TARGET_CC:= ccache $(TARGET_CC)
endif