projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
708b77f
)
netfilter: kmod-nft-netdev: add egress support
author
谢致邦 (XIE Zhibang)
<Yeking@Red54.com>
Mon, 17 Jun 2024 16:07:53 +0000
(16:07 +0000)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 13 Jul 2024 12:54:35 +0000
(14:54 +0200)
The netdev egress hook was added in Linux kernel 5.16.
Link:
https://patchwork.ozlabs.org/project/openwrt/patch/tencent_EB1DF62723D08576A747D0DAE16FFB99B505@qq.com/
Signed-off-by: 谢致邦 (XIE Zhibang) <Yeking@Red54.com>
package/kernel/linux/modules/netfilter.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/netfilter.mk
b/package/kernel/linux/modules/netfilter.mk
index 8bf2be585f309e7162cd824a78c6aed7929cc8ab..3cf63982ba44169380b418f975ec64c116b9a718 100644
(file)
--- a/
package/kernel/linux/modules/netfilter.mk
+++ b/
package/kernel/linux/modules/netfilter.mk
@@
-1217,6
+1217,7
@@
define KernelPackage/nft-netdev
DEPENDS:=+kmod-nft-core
KCONFIG:= \
CONFIG_NETFILTER_INGRESS=y \
+ CONFIG_NETFILTER_EGRESS=y \
CONFIG_NF_TABLES_NETDEV \
CONFIG_NF_DUP_NETDEV \
CONFIG_NFT_DUP_NETDEV \