projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0224be6
)
Prevent SSH keys from being chmoded to 644 (#664), looks like those are the only...
author
Florian Fainelli
<florian@openwrt.org>
Sun, 15 Oct 2006 23:03:46 +0000
(23:03 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Sun, 15 Oct 2006 23:03:46 +0000
(23:03 +0000)
SVN-Revision: 5135
openwrt/target/linux/image/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/target/linux/image/Makefile
b/openwrt/target/linux/image/Makefile
index 566afc30efd8b138e6d36c42936821bb8ab2a400..4b0bcd38d78eea0a78bae5889bd0da59a25fed86 100644
(file)
--- a/
openwrt/target/linux/image/Makefile
+++ b/
openwrt/target/linux/image/Makefile
@@
-22,7
+22,7
@@
install-ib:
cp $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/kernel[-_]*.ipk $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/
install-prepare:
- find $(KDIR)/root -type f -not -perm +0100 | xargs chmod 0644
+ find $(KDIR)/root -type f -not -perm +0100
-not -name 'ssh_host*'
| xargs chmod 0644
find $(KDIR)/root -type f -perm +0100 | xargs chmod 0755
find $(KDIR)/root -type d | xargs chmod 0755
chmod 0777 $(KDIR)/root/tmp