projects
/
openwrt
/
staging
/
robimarko.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9811053
)
enable openssl engine support on ixp4xx
author
Imre Kaloz
<kaloz@openwrt.org>
Sat, 12 Jul 2008 15:42:00 +0000
(15:42 +0000)
committer
Imre Kaloz
<kaloz@openwrt.org>
Sat, 12 Jul 2008 15:42:00 +0000
(15:42 +0000)
SVN-Revision: 11788
package/openssl/Makefile
patch
|
blob
|
history
diff --git
a/package/openssl/Makefile
b/package/openssl/Makefile
index 9fca6b14986b975a4d3fd9941b0dcee2c81b0434..6eafc7ed7d71239c404dd745fa5664c0ac9a1d7d 100644
(file)
--- a/
package/openssl/Makefile
+++ b/
package/openssl/Makefile
@@
-67,8
+67,13
@@
endef
OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
+ifeq ($(BOARD),ixp4xx)
+OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+ no-sse2 no-perlasm
+else
OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
no-engines no-sse2 no-perlasm
+endif
define Build/Configure