projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b0b9ec8
)
kernel: kmod-rtc-ds1307: add dependency to regmap
author
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 25 Nov 2017 21:05:21 +0000
(22:05 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 16 Dec 2017 21:15:08 +0000
(22:15 +0100)
In kernel 4.14 kmod-rtc-ds1307 depends on regmap-i2c, add this missing
dependency.
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/other.mk
b/package/kernel/linux/modules/other.mk
index b4538cc8f2d8ccfb86c63217b302b3ed8db2a264..1c7869e7c6758bc67bf4a8a867103a8c83331f80 100644
(file)
--- a/
package/kernel/linux/modules/other.mk
+++ b/
package/kernel/linux/modules/other.mk
@@
-443,7
+443,7
@@
define KernelPackage/rtc-ds1307
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support
DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
- DEPENDS:=+kmod-i2c-core
+ DEPENDS:=+kmod-i2c-core
+LINUX_4_14:kmod-regmap
KCONFIG:=CONFIG_RTC_DRV_DS1307 \
CONFIG_RTC_CLASS=y
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ds1307.ko